summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2011-04-13 20:32:56 +0100
committerCaolán McNamara <caolanm@redhat.com>2011-04-13 20:35:07 +0100
commita4d841a30eb427bc2aa630c8a0f4d5b8bc5a5027 (patch)
treeaa84617e1225fd2179792760d51cb95c85e4ae6b /configure.in
parent1090e9dbcaf678a2e67720ce02ec4d4c8440459c (diff)
qt4 moc is available in /usr/bin as moc-qt4 on fedora
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bdf5d72b3a08..6f65e4612709 100755
--- a/configure.in
+++ b/configure.in
@@ -6910,10 +6910,14 @@ if test "$test_kde4" = "yes" -a "$ENABLE_KDE4" = "TRUE" ; then
fi
dnl Check for Meta Object Compiler
- AC_PATH_PROG( MOC4, moc, no, [`dirname $qt_lib_dir`/bin:$QT4DIR/bin:$PATH] )
+
+ AC_PATH_PROG( MOC4, moc-qt4, no, [`dirname $qt_lib_dir`/bin:$QT4DIR/bin:$PATH] )
if test "$MOC4" = "no" ; then
- AC_MSG_ERROR([Qt Meta Object Compiler not found. Please specify
+ AC_PATH_PROG( MOC4, moc, no, [`dirname $qt_lib_dir`/bin:$QT4DIR/bin:$PATH] )
+ if test "$MOC4" = "no" ; then
+ AC_MSG_ERROR([Qt Meta Object Compiler not found. Please specify
the root of your Qt installation by exporting QT4DIR before running "configure".])
+ fi
fi
dnl Check for KDE4 headers