summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2012-07-27 10:09:48 +0200
committerJan Holesovsky <kendy@suse.cz>2012-07-27 10:09:48 +0200
commit7ced12c6d010d6c573bce74c2d4c325fd01ed8e1 (patch)
tree7180870778ec32c55b7ab3bff6f75178ec90d860 /configure.in
parenteee01a685a53f2a6d0dc851beec3e770a4c916cf (diff)
Revert "set WINEGCC only when cross compiling"
WINEGCC is needed for the 'build' part of the configuration, and the build part does not know anything of actually being setting up cross-compilation. This reverts commit e7dec2887e511a18a5f9927884c1a1df45fc35f0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5b0aa380c8bf..1a0a72a4073f 100644
--- a/configure.in
+++ b/configure.in
@@ -6106,8 +6106,8 @@ AC_SUBST(BUILD_EPM)
dnl ===================================================================
dnl We need winegcc when building MinGW build to be able to cross-build msi tools
dnl ===================================================================
+AC_PATH_PROG(WINEGCC, winegcc)
if test "$WITH_MINGW" = "yes" -a "$PKGFORMAT" = "msi" ; then
- AC_PATH_PROG(WINEGCC, winegcc)
if test "$WINEGCC" = ""; then
AC_MSG_ERROR([winegcc was not found, please install wine-devel, or wine-devel-32bit])
fi
@@ -6122,7 +6122,6 @@ printf ("hello world\n");
)
CC="$CC_save"
fi
-AC_SUBST(WINEGCC)
dnl ===================================================================
dnl Check for gperf