summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-07-27 14:51:24 +0200
committerDavid Tardon <dtardon@redhat.com>2012-07-27 15:17:20 +0200
commit889f9fc3c3850ed35fbbbbe399acc03c563154b9 (patch)
tree390764e7cb1db50f0170b6c111ecd38060fd2b04 /configure.in
parentc4c54573c6ae5e57fa7eb7d41e155997b829c2be (diff)
update mdds check
Change-Id: I652d84f60a92369466f153a502022ac519312b22
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 2 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 8cc14bca6539..6782015b9168 100644
--- a/configure.in
+++ b/configure.in
@@ -7488,29 +7488,9 @@ if test "$with_system_mdds" = "yes"; then
CPPFLAGS="$CPPFLAGS $MDDS_CPPFLAGS"
AC_CHECK_HEADER(mdds/flat_segment_tree.hpp, [],
[AC_MSG_ERROR(mdds/flat_segment_tree.hpp not found. install mdds)], [])
- AC_CHECK_HEADER(mdds/mixed_type_matrix.hpp, [],
- [AC_MSG_ERROR(mdds/mixed_type_matrix.hpp not found. install mdds >= 0.4.0)], [])
+ AC_CHECK_HEADER(mdds/multi_type_matrix.hpp, [],
+ [AC_MSG_ERROR(mdds/multi_type_matrix.hpp not found. install mdds >= 0.6.0)], [])
CPPFLAGS="$save_CPPFLAGS"
- save_CXXFLAGS="$CXXFLAGS"
- CXXFLAGS="$CXXFLAGS $MDDS_CPPFLAGS"
- AC_MSG_CHECKING([for correct signature of ::mdds::flat_segment_tree])
- AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <mdds/flat_segment_tree.hpp>
-
- int main(int argc, char **argv) {
- ::mdds::flat_segment_tree<long, short> db(0, 100, 0);
- short val;
- if (!db.search(5, val).second)
- return 1;
- return 0;
- }
-]])],[ac_cv_cxx_mdds_flat_segment_tree_correct=yes],[ac_cv_cxx_mdds_flat_segment_tree_correct=no],[])
-
- if test "$ac_cv_cxx_mdds_flat_segment_tree_correct" = "yes"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_ERROR([no, install mdds >= 0.5.0])
- fi
- CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])