summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-07-30 18:15:45 +0300
committerTor Lillqvist <tml@iki.fi>2012-07-30 18:16:37 +0300
commit9cd80e1bebf22ab4c54e0196d54588bc137048d8 (patch)
tree040eed0f6b091066cf9d4163dee85e1ef5f45c62 /configure.in
parent9348c529d34b0bb457e750b3d5bcbb348995367e (diff)
Avoid "note: the mangling of 'va_list' has changed in GCC 4.4" messages
Change-Id: I289aa31a6ef984931f888c127c1a7c30f64b53fc
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ba5f3de78af1..48ccef83fb0f 100644
--- a/configure.in
+++ b/configure.in
@@ -169,9 +169,9 @@ if test -n "$with_android_ndk"; then
test -z "$STRIP" && STRIP=$ANDROID_ABI_PREBUILT_BIN/$android_gcc_prefix-strip
if test $host_cpu = arm; then
- ANDROIDCFLAGS="-march=armv7-a -mfloat-abi=softfp -mfpu=neon -Wl,--fix-cortex-a8 --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-arm -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${toolchain_version_subdir}libs/armeabi-v7a"
+ ANDROIDCFLAGS="-Wno-psabi -march=armv7-a -mfloat-abi=softfp -mfpu=neon -Wl,--fix-cortex-a8 --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-arm -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${toolchain_version_subdir}libs/armeabi-v7a"
else # x86
- ANDROIDCFLAGS="-march=atom --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-x86 -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${toolchain_version_subdir}libs/x86"
+ ANDROIDCFLAGS="-Wno-psabi -march=atom --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-x86 -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${toolchain_version_subdir}libs/x86"
fi
# When using the 4.6 or newer toolchain, use the gold linker