summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-03-30 01:59:36 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-03-30 01:59:36 -0500
commitdf72f234c296ae7b3d708a435419f93f817f36c6 (patch)
treea42a3badf03a21fef16f9fec4a1c593ac38d4adf /configure.in
parentfebdb8aeb7dbb07b7380808ce0cecfa7bb2b6101 (diff)
don't force dependecy on shasum when it is not needed
shasum is only needed to detect a bug in some version of gnumkae do not burden platform with a non-impacted gnu make with that requirement
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index face6c2c4108..e150c891b42c 100644
--- a/configure.in
+++ b/configure.in
@@ -3614,14 +3614,6 @@ AC_MSG_CHECKING([whether to enable pch feature])
AC_MSG_RESULT([no, obsolete])
dnl ===================================================================
-dnl Search all the common names for sha1sum
-dnl ===================================================================
-AC_PATH_PROGS(SHA1SUM, sha1sum sha1 shasum)
-if test -z "$SHA1SUM"; then
- AC_MSG_ERROR([install the approproate SHA-1 checksumming program for this OS])
-fi
-
-dnl ===================================================================
dnl Search all the common names for GNU make
dnl ===================================================================
AC_MSG_CHECKING([for GNU make])
@@ -3653,6 +3645,14 @@ if test "$_make_longver" -ge "038200"; then
elif test "$_make_longver" -ge "038100"; then
AC_MSG_RESULT([$GNUMAKE $_make_version])
+
+ dnl ===================================================================
+ dnl Search all the common names for sha1sum
+ dnl ===================================================================
+ AC_PATH_PROGS(SHA1SUM, sha1sum sha1 shasum)
+ if test -z "$SHA1SUM"; then
+ AC_MSG_ERROR([install the approproate SHA-1 checksumming program for this OS])
+ fi
AC_MSG_CHECKING([for GNU make bug 20033])
TESTGMAKEBUG20033=`mktemp -d tmp.XXXXXX`
cat > $TESTGMAKEBUG20033/Makefile << EOF