summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFrancois Tigeot <ftigeot@wolfpond.org>2011-02-27 09:47:03 +0100
committerFrancois Tigeot <ftigeot@wolfpond.org>2011-02-27 09:47:03 +0100
commit29b55434cb4c5816a2d2f4544e733edfc9f1fea8 (patch)
tree7ae33bc773cad1d1c29a6539bb9e36673c55b3df /configure.in
parent35f31a7e944037ecbcb9d1991ffffe756a173678 (diff)
Use system OpenSSL on DragonFly.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ac21733f8769..d66559803bec 100755
--- a/configure.in
+++ b/configure.in
@@ -5439,7 +5439,8 @@ fi
dnl ===================================================================
dnl Check for system openssl
dnl ===================================================================
-if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" && test "$with_system_openssl" != "no"; then
+if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o \
+ "$_os" = "DragonFly" && test "$with_system_openssl" != "no"; then
with_system_openssl=yes
fi
AC_MSG_CHECKING([which libssl to use])
@@ -5448,7 +5449,8 @@ if test -n "$with_system_openssl" -o -n "$with_system_libs" && \
AC_MSG_RESULT([external])
# Mac OS builds should get out without extra stuff is the Mac porters'
# wish. And pkg-config is although Xcode ships a .pc for openssl
- if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" ; then
+ if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o \
+ "$_os" = "DragonFly"; then
OPENSSL_CFLAGS=
OPENSSL_LIBS="-lssl -lcrypto"
else