summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-04-16 14:50:19 +0200
committerDavid Tardon <dtardon@redhat.com>2012-04-16 20:24:23 +0200
commita420516af36b3c7b6b657ffdef8cb0ef0a6ae1b4 (patch)
treee47a77a82e5ce5c941c31ed4951f8a9c943698bf /configure.in
parentafbc8993bdff272eb6712333c89715c9a1de0533 (diff)
mingw: unbreak make check
Even if it does nothing because there is no installation available .-)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 624464a48f67..1792d2b29ea4 100644
--- a/configure.in
+++ b/configure.in
@@ -8160,6 +8160,22 @@ fi
AC_SUBST(WINDOWS_SDK_HOME)
dnl =========================================
+dnl Check for uuidgen
+dnl =========================================
+if test "$_os" = "WINNT"; then
+ if test "$WITH_MINGW" = "yes"; then
+ AC_PATH_PROG([UUIDGEN], [uuid])
+ if test -z "$UUIDGEN"; then
+ AC_MSG_ERROR([uuid is needed for dev-install])
+ fi
+ else
+ # presence is already tested above in the WINDOWS_SDK_HOME check
+ UUIDGEN=uuidgen.exe
+ AC_SUBST(UUIDGEN)
+ fi
+fi
+
+dnl =========================================
dnl Check for the Microsoft DirectX SDK.
dnl =========================================
if test -n "$ENABLE_DIRECTX" -a "$_os" = "WINNT"; then