summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mst@openoffice.org>2010-10-18 13:01:28 +0200
committerMichael Stahl <mst@openoffice.org>2010-10-18 13:01:28 +0200
commit66b0482973dca797c00971e3f6b843d6e7a88625 (patch)
tree2079c03290c5b2b1c9072d7bb601a457e65cb151 /configure.in
parent5fd4bebe16e6b75bfb115f66867881758d12a53e (diff)
parent3625b4bc39d56b868da6193793d3f9611494a4eb (diff)
sw34bf01: merge fix for #i114999#
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in91
1 files changed, 82 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 51608cdb137d..5530170cd12a 100644
--- a/configure.in
+++ b/configure.in
@@ -198,6 +198,10 @@ AC_ARG_ENABLE(gtk,
[ --disable-gtk Determines whether to use Gtk+ vclplug on platforms
where Gtk+ is available.
],,enable_gtk=yes)
+AC_ARG_ENABLE(gstreamer,
+[ --disable-gstreamer Determines whether to use the GStreamer media
+ backend on platforms where GStreamer is available.
+],,enable_gstreamer=yes)
AC_ARG_ENABLE(systray,
[ --disable-systray Determines whether to build the systray quickstarter.
],,enable_systray=yes)
@@ -546,6 +550,12 @@ AC_ARG_WITH(system-altlinuxhyph,
AC_ARG_WITH(system-lpsolve,
[ --with-system-lpsolve Use lpsolve already on system
],,)
+AC_ARG_WITH(system-libtextcat,
+[ --with-system-libtextcat Use libtextcat already on system
+],,)
+AC_ARG_WITH(external-libtextcat-data,
+[ --with-system-libtextcat-data Use libtextcat data already on system
+],,)
AC_ARG_WITH(system-cppunit,
[ --with-system-cppunit Use cppunit already on system
],,)
@@ -926,6 +936,7 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
_os=SunOS
AC_PATH_PROG( GNUTAR, gtar,,$PATH:/usr/sfw/bin)
if test -z "$GNUTAR"; then
@@ -960,7 +971,8 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
- _os=Linux
+ test_gstreamer=yes
+ _os=Linux
;;
gnu)
test_cups=no
@@ -970,6 +982,7 @@ case "$build_os" in
test_cups=no
test_cairo=yes
test_freetype=no
+ test_gstreamer=no
_os=WINNT
;;
darwin*) # Mac OS X
@@ -978,6 +991,7 @@ case "$build_os" in
test_cairo=yes
test_randr=no
test_freetype=no
+ test_gstreamer=no
_os=Darwin
if test "$enable_systray" = "yes" && test "$enable_gtk" != "no"; then
AC_MSG_WARN([Disabling gtk-quickstarter - not supported on Mac. Use --disable-systray])
@@ -991,6 +1005,7 @@ case "$build_os" in
test_randr=no
test_gtk=no
test_freetype=no
+ test_gstreamer=no
_os=OS2
;;
freebsd*)
@@ -1001,6 +1016,7 @@ case "$build_os" in
test_cups=yes
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
if test -n "$with_os_version"; then
OSVERSION="$with_os_version"
@@ -1035,6 +1051,7 @@ case "$build_os" in
test_cups=no
test_randr=yes
test_freetype=yes
+ test_gstreamer=yes
PTHREAD_CFLAGS="-pthread"
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
@@ -1043,6 +1060,7 @@ case "$build_os" in
test_cups=no
test_randr=no
test_freetype=yes
+ test_gstreamer=yes
PTHREAD_LIBS=-pthread
echo "AIX is an alpha port --- Use at own risk" >> warn
_os=AIX
@@ -1454,7 +1472,8 @@ if test \( "$_os" != "WINNT" -o "$WITH_MINGWIN" = "yes" \) -a "$GCC" = "yes"; th
fi
if test "$_os" = "Darwin" -a "$GCCVER" -ge "040100" ; then
if test -z "$save_CC" -a -x "$GCC_HOME/bin/gcc-4.0" ; then
- CC=$GCC_HOME/bin/gcc-4.0
+ export CC=$GCC_HOME/bin/gcc-4.0
+ dnl export CC to have it available in set_soenv -> config.guess
GCCVER2=`"$CC" -dumpversion | $AWK -F. '{ print \$1*10000+\$2*100+\$3 }'`
if test "$GCCVER2" -ge "040000" -a "$GCCVER2" -lt "040100" ; then
GCCVER=$GCCVER2
@@ -3640,12 +3659,6 @@ if test -n "$with_system_cppunit" -o -n "$with_system_libs" && \
# a system-cppunit before the first version using a proper cppunit
# (and that being 1.12.1) anyway
PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.1 )
- AC_MSG_CHECKING([STL compatibility])
- if test "$WITH_STLPORT" != "no"; then
- AC_MSG_ERROR([to use system cppunit you need to use --without-stlport])
- else
- AC_MSG_RESULT([OK])
- fi
else
AC_MSG_RESULT([internal])
SYSTEM_CPPUNIT=NO
@@ -3852,7 +3865,11 @@ if test -n "$with_system_lucene" -o -n "$with_system_libs" && \
[
AC_CHECK_FILE(/usr/share/java/lucene-core.jar,
[ LUCENE_CORE_JAR=/usr/share/java/lucene-core.jar ],
- [ AC_MSG_ERROR(lucene-core.jar replacement not found)]
+ [ AC_CHECK_FILE(/usr/share/java/lucene.jar,
+ [ LUCENE_CORE_JAR=/usr/share/java/lucene.jar ],
+ [ AC_MSG_ERROR(lucene-core.jar replacement not found)]
+ )
+ ]
)
]
)
@@ -5195,6 +5212,38 @@ else
fi
AC_SUBST(SYSTEM_LPSOLVE)
+dnl ===================================================================
+dnl Checking for libtextcat
+dnl ===================================================================
+AC_MSG_CHECKING([which libtextcat to use])
+if test -n "$with_system_libtextcat" && test "$with_system_libtextcat" != "no"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_LIBTEXTCAT=YES
+ AC_CHECK_HEADER(libtextcat/textcat.h, [],
+ [ AC_MSG_ERROR(libtextcat headers not found.)], [])
+ AC_CHECK_LIB(textcat, special_textcat_Init, ,
+ [ AC_MSG_ERROR(libtextcat library not found or not suitable. libtextcat typically needs to be patched)], [])
+else
+ AC_MSG_RESULT([internal])
+ SYSTEM_LIBTEXTCAT=NO
+ BUILD_TYPE="$BUILD_TYPE LIBTEXTCAT"
+fi
+AC_SUBST(SYSTEM_LIBTEXTCAT)
+
+AC_MSG_CHECKING([which libtextcat data directory to use])
+if test -n "$with_system_libtextcat_data" && test "$with_system_libtextcat_data" != "no"; then
+ if test "$with_system_libtextcat_data" = "yes"; then
+ SYSTEM_LIBTEXTCAT_DATA=file:///usr/share/libtextcat
+ else
+ SYSTEM_LIBTEXTCAT_DATA=file://$with_system_libtextcat_data
+ fi
+ AC_MSG_RESULT([$SYSTEM_LIBTEXTCAT_DATA])
+else
+ AC_MSG_RESULT([internal])
+ BUILD_TYPE="$BUILD_TYPE LIBTEXTCATDATA"
+fi
+AC_SUBST(SYSTEM_LIBTEXTCAT_DATA)
+
dnl ***************************************
dnl testing libc version for Linux...
dnl ***************************************
@@ -5751,6 +5800,29 @@ AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
dnl ===================================================================
+dnl Check whether the GStreamer libraries are available.
+dnl ===================================================================
+
+GSTREAMER_CFLAGS=""
+GSTREAMER_LIBS=""
+ENABLE_GSTREAMER=""
+
+if test "$test_gstreamer" = "yes"; then
+ AC_MSG_CHECKING([whether to build the GStreamer media backend])
+ if test "x$enable_gstreamer" != "xno" ; then
+ PKG_CHECK_MODULES( GSTREAMER, gtk+-2.0 >= 2.4 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 ,,AC_MSG_ERROR([requirements to build the GStreamer media backend not met. Use --disable-gstreamer or install the missing packages]))
+ ENABLE_GSTREAMER="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST(ENABLE_GSTREAMER)
+AC_SUBST(GSTREAMER_CFLAGS)
+AC_SUBST(GSTREAMER_LIBS)
+
+
+dnl ===================================================================
dnl Check whether the Cairo libraries are available.
dnl ===================================================================
@@ -6555,6 +6627,7 @@ dnl ===================================================================
AC_MSG_CHECKING([whether to include AFMs])
if test "$with_afms" != "no"; then
AC_MSG_RESULT([yes])
+ BUILD_TYPE="$BUILD_TYPE AFMS"
else
AC_MSG_RESULT([no])
WITHOUT_AFMS=YES