summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorobo <obo@openoffice.org>2010-06-22 12:09:13 +0200
committerobo <obo@openoffice.org>2010-06-22 12:09:13 +0200
commit6aeea58d28f6b0821a8ec25de42b28b38307e2e2 (patch)
tree41af364b650546d8bf44932212253edbae724d26 /configure.in
parentbbc48b6af5c43693ef69594917c0d5a139da0c89 (diff)
parentb002f7e29934380dbe544607df3c72cf123daa65 (diff)
CWS-TOOLING: integrate CWS mythes12
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 048bdc37d924..02faf69d6198 100644
--- a/configure.in
+++ b/configure.in
@@ -5090,15 +5090,30 @@ AC_MSG_CHECKING([which mythes to use])
if test -n "$with_system_mythes" && test "$with_system_mythes" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_MYTHES=YES
- AC_CHECK_HEADER(mythes.hxx, [],
- [ AC_MSG_ERROR(mythes.hxx headers not found.)], [])
- AC_CHECK_LIB(mythes, main, [],
- [ AC_MSG_ERROR(mythes library not found.)], [])
+ AC_LANG_PUSH([C++])
+ PKG_CHECK_MODULES(MYTHES, mythes, MYTHES_PKGCONFIG=yes, MYTHES_PKGCONFIG=no)
+ if test "$MYTHES_PKGCONFIG" = "no"; then
+ AC_CHECK_HEADER(mythes.hxx, [],
+ [ AC_MSG_ERROR(mythes.hxx headers not found.)], [])
+ AC_CHECK_LIB(mythes-1.2, main, [],
+ [ MYTHES_FOUND=no], [])
+ if test "$MYTHES_FOUND" = "no"; then
+ AC_CHECK_LIB(mythes, main, [MYTHES_FOUND=yes],
+ [ MYTHES_FOUND=no], [])
+ fi
+ if test "$MYTHES_FOUND" = "no"; then
+ AC_MSG_ERROR([mythes library not found!.])
+ fi
+ fi
+ AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])
SYSTEM_MYTHES=NO
+ BUILD_TYPE="$BUILD_TYPE MYTHES"
fi
AC_SUBST(SYSTEM_MYTHES)
+AC_SUBST(MYTHES_CFLAGS)
+AC_SUBST(MYTHES_LIBS)
dnl ===================================================================
dnl Checking for lpsolve