summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2012-05-12 09:37:20 +0100
committerCaolán McNamara <caolanm@redhat.com>2012-05-12 09:53:44 +0100
commit27cf5f8140c99937aa3e3d7ee3c20a11dd1cabe1 (patch)
treee68cb731eb8cafc42bcb7b46733484ef418489be /configure.in
parentda2f9e3901d7eccf6633d4d71160b33ae060a624 (diff)
cross-compilation with mingw32 woes in i18npool
seems the situation is that we link to the mingw32-system-icu but build the bundled icu natively in order to use its tools at build time. Which means we need the ICU_RECLASSIFIED_CLOSE_PARENTHESIS ICU_RECLASSIFIED_PREPEND_SET_EMPTY defaults to match the internal icu defaults Change-Id: I09a693d795b956789170cc65a582a4367366acaa
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 12 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index 71b8f1f0b772..595ba71bbb0f 100644
--- a/configure.in
+++ b/configure.in
@@ -7690,8 +7690,8 @@ SYSTEM_GENCMN=
ICU_MAJOR=
ICU_MINOR=
ICU_MICRO=
-ICU_RECLASSIFIED_CLOSE_PARENTHESIS=
-ICU_RECLASSIFIED_PREPEND_SET_EMPTY=
+ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
+ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
AC_MSG_CHECKING([which icu to use])
if test "$with_system_icu" = "yes"; then
AC_MSG_RESULT([external])
@@ -7712,16 +7712,6 @@ if test "$with_system_icu" = "yes"; then
ICU_MAJOR=`echo $ICU_VERSION | cut -d"." -f1`
ICU_MINOR=`echo $ICU_VERSION | cut -d"." -f2`
ICU_MICRO=`echo $ICU_VERSION | cut -d"." -f3`
- if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4"; then
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
- else
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="NO"
- fi
- if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "9"; then
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
- else
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="NO"
- fi
if test "$ICU_MAJOR" -ge "4"; then
AC_MSG_RESULT([OK, $ICU_VERSION])
@@ -7744,16 +7734,6 @@ if test "$with_system_icu" = "yes"; then
You can use --with-system-icu-for-build=force to use it anyway.])
fi
fi
- if test "$ICU_MAJOR_FOR_BUILD" -ge "5" -o "$ICU_MAJOR_FOR_BUILD" = "4" -a "$ICU_MINOR_FOR_BUILD" -ge "4"; then
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
- else
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="NO"
- fi
- if test "$ICU_MAJOR_FOR_BUILD" -ge "5" -o "$ICU_MAJOR_FOR_BUILD" = "4" -a "$ICU_MINOR_FOR_BUILD" -ge "9"; then
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
- else
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="NO"
- fi
fi
if test "$cross_compiling" != "yes" -o "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force"; then
@@ -7771,6 +7751,16 @@ You can use --with-system-icu-for-build=force to use it anyway.])
if test -z "$SYSTEM_GENCMN"; then
AC_MSG_ERROR([\'gencmn\' not found in \$PATH, install the icu development tool \'gencmn\'])
fi
+ if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4"; then
+ ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
+ else
+ ICU_RECLASSIFIED_CLOSE_PARENTHESIS="NO"
+ fi
+ if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "9"; then
+ ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
+ else
+ ICU_RECLASSIFIED_PREPEND_SET_EMPTY="NO"
+ fi
fi
libo_MINGW_CHECK_DLL([ICUDATA], [icudata][$ICU_MAJOR][$ICU_MINOR])
@@ -7779,8 +7769,6 @@ You can use --with-system-icu-for-build=force to use it anyway.])
else
AC_MSG_RESULT([internal])
SYSTEM_ICU="NO"
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
- ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
BUILD_TYPE="$BUILD_TYPE ICU"
fi