summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-01-05 19:40:38 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-01-05 19:43:14 +0100
commit58ab12acf576a765ec47cc2753ba57643e51d653 (patch)
tree79c07bddbdf3e8e6db677eb0b94e8a2880d308c1 /configure.in
parent7482e974117df2bdc737785efdf9eb410787c7b4 (diff)
Switch from autodoc to doxygen for SDK C++ documentation.
* New build prerequisite doxygen (controllable via --with-doxygen). * Adapted various headers to slightly different doxygen documentation syntax, but much clean up still remains to be done (i.e., warnings emitted by doxygen fixed).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2683a329f8a3..8f3b6da50b2f 100644
--- a/configure.in
+++ b/configure.in
@@ -1501,6 +1501,18 @@ AC_ARG_WITH(perl-home,
],
,)
+AC_ARG_WITH(
+ [doxygen],
+ AS_HELP_STRING(
+ [--with-doxygen],
+ [Specifies the doxygen executable to use when generating ODK C/C++
+ documentation. --without-doxygen disables generation of ODK C/C++
+ documentation. Not relevant in the --disable-odk case.])
+ [
+ Usage: --with-doxygen=<absolute path to doxygen executable>
+ ],,
+ [with_doxygen=yes])
+
AC_ARG_WITH(cl-home,
AS_HELP_STRING([--with-cl-home],
[For Windows NT users, please supply the path for the Microsoft C/C++
@@ -9888,6 +9900,29 @@ location (/usr/share/java), specify its pathname via
fi
AC_SUBST(OOO_JUNIT_JAR)
+if test "$enable_odk" = no; then
+ unset DOXYGEN
+else
+ if test "$with_doxygen" = no; then
+ AC_MSG_CHECKING([for doxygen])
+ unset DOXYGEN
+ AC_MSG_RESULT([no])
+ else
+ if test "$with_doxygen" = yes; then
+ AC_PATH_PROG([DOXYGEN], [doxygen])
+ if test -z "$DOXYGEN"; then
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([doxygen not found in \$PATH; specify its pathname via --with-doxygen=..., or disable its use via --without-doxygen])
+ fi
+ else
+ AC_MSG_CHECKING([for doxygen])
+ DOXYGEN=$with_doxygen
+ AC_MSG_RESULT([$DOXYGEN])
+ fi
+ fi
+fi
+AC_SUBST([DOXYGEN])
+
dnl ===================================================================
dnl Product version
dnl ===================================================================