summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-12-31 10:39:55 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-12-31 10:39:55 -0600
commit9034973de5b7f62121a62c56757bf20e490de654 (patch)
tree80106f1231d9034a780a743b1a0248213c20c255 /configure.in
parentd64bdc0f1ebfa864598709f23fd14f528955bbc3 (diff)
fix PathFormat, use build_os not host_os
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1f8c5d0ec47f..ab10538d92ef 100644
--- a/configure.in
+++ b/configure.in
@@ -16,7 +16,7 @@ MINGW_EXTERNAL_DLLS=""
PathFormat()
{
formatted_path="$1"
- if test "$host_os" = "cygwin" ; then
+ if test "$build_os" = "cygwin" ; then
pf_part1=
pf_conv_to_dos=
for pf_part in $formatted_path ; do
@@ -29,8 +29,8 @@ PathFormat()
if test "$pf_conv_to_dos" = "yes" ; then
formatted_path=`cygpath -d "$formatted_path"`
fi
- fp_count_colon=`cat "$formatted_path" | grep -c "[:]"`
- fp_count_slash=`cat "$formatted_path" | grep -c "[/]"`
+ fp_count_colon=`echo "$formatted_path" | grep -c "[:]"`
+ fp_count_slash=`echo "$formatted_path" | grep -c "[/]"`
if test "$fp_count_slash$fp_count_colon" != "00" ; then
if test "$fp_count_colon" = "0" ; then
formatted_path=`realpath "$formatted_path"`