summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-01-23 15:08:36 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-01-23 20:31:57 +0100
commitc97d74b5f0608866bad3f7ae943811bdff4f7986 (patch)
tree1c7ec8a333f138e4d90a3c6a497d35f1da64c975 /configure.in
parent95780ec73990f96dc16fc677c895d00fa1360008 (diff)
fdo#45090: Changed postgresql-sdbc from bundled oxt to proper optional part.
Replaced --enable-ext-postgresql-sdbc with --disable-postgresql-sdbc. Renamed postgresql-sdbc.uno{.ini,rc} to consistent postgresql-sdbc.ini (which made the code a little easier). Signed-off-by: Fridrich Štrba <fridrich.strba@bluewin.ch> (cherry picked from commit 3a7ae48b6f610899200ae2800706533f7c4c9f80) Conflicts: configure.in connectivity/source/drivers/postgresql/makefile.mk
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 84beec313327..2f7bd61382c0 100644
--- a/configure.in
+++ b/configure.in
@@ -427,11 +427,6 @@ AC_ARG_ENABLE(ext-pdfimport,
[Disable the PDF Import extension.])
)
-AC_ARG_ENABLE(ext-postgresql-sdbc,
- AS_HELP_STRING([--enable-ext-postgresql-sdbc],
- [Enable the build of the PostgreSQL-SDBC extension.])
-)
-
AC_ARG_ENABLE(ext-presenter-console,
AS_HELP_STRING([--disable-ext-presenter-console],
[Disable the Presenter Console extension.])
@@ -873,6 +868,11 @@ AC_ARG_ENABLE(silent-msi,
[Enable MSI with LIMITUI=1 (silent install).]),
,)
+AC_ARG_ENABLE(postgresql-sdbc,
+ AS_HELP_STRING([--disable-postgresql-sdbc],
+ [Disable the build of the PostgreSQL-SDBC driver.])
+)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -1199,7 +1199,7 @@ AC_ARG_WITH(system-mysql-cppconn,
AC_ARG_WITH(system-postgresql,
AS_HELP_STRING([--with-system-postgresql],
[Use PostgreSQL libraries already on system, for building the PostgreSQL-SDBC
- extension. If pg_config is not in PATH, use PGCONFIG to point to it.]),,
+ driver. If pg_config is not in PATH, use PGCONFIG to point to it.]),,
[with_system_postgresql="$with_system_libs"])
AC_ARG_WITH(libpq-path,
@@ -6118,13 +6118,11 @@ fi
dnl ===================================================================
dnl Check for PostgreSQL stuff
dnl ===================================================================
-if test "x$enable_ext_postgresql_sdbc" = "xyes"; then
- if test "x$enable_extension_integration" = "xyes"; then
- SCPDEFS="$SCPDEFS -DWITH_EXTENSION_POSTGRESQL"
- fi
+if test "x$enable_postgresql_sdbc" != "xno"; then
+ SCPDEFS="$SCPDEFS -DWITH_POSTGRESQL_SDBC"
# if/when anything else than PostgreSQL uses Kerberos,
-# move this out of `test "x$enable_ext_postgresql_sdbc" = "xyes"'
+# move this out of `test "x$enable_postgresql_sdbc" != "xno"'
WITH_KRB5=NO
WITH_GSSAPI=no
case "$_os" in