summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2012-09-15 09:35:04 -0400
committerDavid Tardon <dtardon@redhat.com>2012-10-07 10:42:20 +0200
commit4b17650868da44dea228d524c38615786a256460 (patch)
treeca44146bf9a9763d0af079af90d6e462dcfcab79 /configure.in
parenta97fdbda6b568d776e04e27dda7c26d33b88c8c5 (diff)
Fix ccache with MSVC
Change-Id: I0721a8d0aa584051d1e16b327c3cd1352eedf253
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 17 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 83c6f4840fa9..1c71c13ba612 100644
--- a/configure.in
+++ b/configure.in
@@ -3289,26 +3289,23 @@ AC_SUBST(DBGHELP_DLL)
#
# prefix C with ccache if needed
#
-if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
- if test "$CCACHE" != ""; then
- AC_MSG_CHECKING([whether $CC is already ccached])
-
- AC_LANG_PUSH([C])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS --ccache-skip -O2"
- dnl an empty program will do, we're checking the compiler flags
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],
- [use_ccache=yes], [use_ccache=no])
- if test $use_ccache = yes; then
- AC_MSG_RESULT([yes])
- else
- CC="$CCACHE $CC"
- AC_MSG_RESULT([no])
- fi
- CFLAGS=$save_CFLAGS
- AC_LANG_POP([C])
- fi
-
+if test "$CCACHE" != ""; then
+ AC_MSG_CHECKING([whether $CC is already ccached])
+
+ AC_LANG_PUSH([C])
+ save_CFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS --ccache-skip -O2"
+ dnl an empty program will do, we're checking the compiler flags
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],
+ [use_ccache=yes], [use_ccache=no])
+ if test $use_ccache = yes; then
+ AC_MSG_RESULT([yes])
+ else
+ CC="$CCACHE $CC"
+ AC_MSG_RESULT([no])
+ fi
+ CFLAGS=$save_CFLAGS
+ AC_LANG_POP([C])
fi
#