summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-09-27 21:45:47 +0200
committerMichael Stahl <mstahl@redhat.com>2012-09-28 16:49:07 +0200
commit78b59b8302e79fad71bfff66d5b88db80527e6a1 (patch)
tree877b7bec05cebfa44db36af96b292874d20e3a39 /configure.in
parent40e0ebff76d839a548638ca8709c68c56e2b926c (diff)
gbuild: clean up usage of weird x11_extensions module etc.
Move libraries using those headers to RepositoryExternal.mk and also move pkg-config invocation to configure. Change-Id: I17a240fcba83a98f3f248f15b34d245f941c62e2
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 17b13c61bf05..c1abd8aa2ddb 100644
--- a/configure.in
+++ b/configure.in
@@ -8535,6 +8535,7 @@ dnl ===================================================================
AC_MSG_CHECKING([whether to use Xrender])
if test "$WANT_X11" = "yes" -a "$test_xrender" = "yes"; then
AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES(XRENDER, xrender)
AC_CHECK_LIB([Xrender], [XRenderQueryVersion], [:],
[AC_MSG_ERROR(libXrender not found or functional)], [])
AC_MSG_CHECKING([which Xrender headers to use])
@@ -8548,6 +8549,8 @@ if test "$WANT_X11" = "yes" -a "$test_xrender" = "yes"; then
else
AC_MSG_RESULT([no])
fi
+AC_SUBST(XRENDER_CFLAGS)
+AC_SUBST(XRENDER_LIBS)
dnl ===================================================================
dnl Check for XRandr