summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@openoffice.org>2010-04-27 17:16:50 +0200
committerRene Engelhard <rene@openoffice.org>2010-04-27 17:16:50 +0200
commit0cce173a5bae32982a3430871b131f663280cc25 (patch)
tree807b0a90578cc4bd8a9c3f733df5a9bb7d61c517 /configure.in
parenta0de0def4a49a63c6675a622123b793da8b4c78d (diff)
mythes12: update system-mythes check for 1.2.0; add missing AC_LANG_PUSH/POP
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 91ff5806fbe5..756ddb2a78fe 100644
--- a/configure.in
+++ b/configure.in
@@ -5090,15 +5090,29 @@ AC_MSG_CHECKING([which mythes to use])
if test -n "$with_system_mythes" && test "$with_system_mythes" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_MYTHES=YES
- AC_CHECK_HEADER(mythes.hxx, [],
- [ AC_MSG_ERROR(mythes.hxx headers not found.)], [])
- AC_CHECK_LIB(mythes, main, [],
- [ AC_MSG_ERROR(mythes library not found.)], [])
+ AC_LANG_PUSH([C++])
+ PKG_CHECK_MODULES(MYTHES, mythes, MYTHES_PKGCONFIG=yes, MYTHES_PKGCONFIG=no)
+ if test "$MYTHES_PKGCONFIG" = "no"; then
+ AC_CHECK_HEADER(mythes.hxx, [],
+ [ AC_MSG_ERROR(mythes.hxx headers not found.)], [])
+ AC_CHECK_LIB(mythes-1.2, main, [],
+ [ MYTHES_FOUND=no], [])
+ if test "$MYTHES_FOUND" = "no"; then
+ AC_CHECK_LIB(mythes, main, [],
+ [ MYTHES_FOUND=no], [])
+ fi
+ if test "$MYTHES_FOUND" = "no"; then
+ AC_MSG_ERROR([mythes library not found!.])
+ fi
+ fi
+ AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])
SYSTEM_MYTHES=NO
fi
AC_SUBST(SYSTEM_MYTHES)
+AC_SUBST(MYTHES_CFLAGS)
+AC_SUBST(MYTHES_LIBS)
dnl ===================================================================
dnl Checking for lpsolve