summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-03-18 11:39:45 +0100
committerDavid Tardon <dtardon@redhat.com>2012-03-18 21:23:41 +0100
commit1f09f96e95a74308fee7a1549234c2c364e55e4f (patch)
treea1018d19254f1aa888a906357ba7850b734ce4f8 /configure.in
parent1118f57582aaa7275a8fe1d1460e1515c111ac2e (diff)
mingw: allow use of system zlib
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa5cac5473b0..189ad8702188 100644
--- a/configure.in
+++ b/configure.in
@@ -5738,12 +5738,21 @@ if test "$with_system_zlib" = "yes"; then
[AC_MSG_ERROR(zlib.h not found. install zlib)], [])
AC_CHECK_LIB(z, deflate, [ ZLIB=-lz ],
[AC_MSG_ERROR(zlib not found or functional)], [])
+ if test "$WITH_MINGW" = "yes"; then
+ # we need minizip too
+ PKG_CHECK_MODULES([MINIZIP], [minizip])
+ libo_MINGW_CHECK_DLL([MINIZIP], [libminizip])
+ SYSTEM_MINIZIP=YES
+ fi
else
AC_MSG_RESULT([internal])
SYSTEM_ZLIB=NO
+ SYSTEM_MINIZIP=NO
BUILD_TYPE="$BUILD_TYPE ZLIB"
fi
AC_SUBST(SYSTEM_ZLIB)
+AC_SUBST([SYSTEM_MINIZIP])
+AC_SUBST([MINGW_MINIZIP_DLL])
dnl ===================================================================
dnl Check for system jpeg