summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-02-06 14:29:18 +0200
committerTor Lillqvist <tml@iki.fi>2012-02-06 16:57:40 +0200
commitf8d30ec82d55f85a80ceda798a9e1a7ce0750035 (patch)
tree089008411c0364219f3dec951da68c07b8dfe420 /configure.in
parent3a8a275d74ea8e2147e59d2578539b6bbc60927b (diff)
Attempt to disable database connectivity for iOS for now
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 33facd89cf4a..f14d675cf980 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,11 @@ AC_ARG_ENABLE(ext-barcode,
[Enable the Barcode extension.])
)
+AC_ARG_ENABLE(database-connectivity,
+ AS_HELP_STRING([--disable-database-connectivity],
+ [Disable various database connectivity.])
+)
+
AC_ARG_ENABLE(ext-diagram,
AS_HELP_STRING([--enable-ext-diagram],
[Enable the SmART Gallery (Diagram) extension.])
@@ -1996,6 +2001,22 @@ if test $_os != iOS -a $_os != Android; then
BUILD_TYPE="$BUILD_TYPE DESKTOP"
fi
+dnl Decide whether to build database connectivity stuff (including
+dnl Base) or not. We probably don't want to on non-desktop OSes.
+
+if test -z "$enable_database_connectivity"; then
+ # Do enable database connectivity for Android for now as otherwise
+ # we presumably will get linking errors... We are not as far in
+ # the work for iOS, so we might as well disable it for iOS already.
+ if test $_os != iOS; then
+ enable_database_connectivity=yes
+ fi
+fi
+
+if test "$enable_database_connectivity" = yes; then
+ BUILD_TYPE="$BUILD_TYPE DBCONNECTIVITY"
+fi
+
dnl ===================================================================
dnl Extra check for Windows. Cygwin builds need gcc to build dmake
dnl although MSVC is used to build other build-time tools and
@@ -6737,6 +6758,8 @@ if test "$with_system_odbc" = "yes"; then
AC_CHECK_HEADER(sqlext.h, [],
[AC_MSG_ERROR(odbc not found. install odbc)], [])
+elif test "$enable_database_connectivity" != yes; then
+ AC_MSG_RESULT([none])
else
AC_MSG_RESULT([internal])
SYSTEM_ODBC_HEADERS=NO