summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-11-11 15:50:29 +0100
committerTomas Chvatal <tchvatal@suse.cz>2011-11-11 15:51:10 +0100
commitdb7ab4ac1412143c2151787224e64e0cd090efb4 (patch)
treead1efafb5df4a592a32c37216255bef0695e4560 /configure.in
parenta9d167ba98672277c1ac57c5fe54965c21c02446 (diff)
Add nsplugin switch so we dont bind nsplugin building to gtk switch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 421289be3f46..b5d21ee91115 100644
--- a/configure.in
+++ b/configure.in
@@ -740,6 +740,11 @@ AC_ARG_ENABLE(zenity,
[Do not display a build icon in the notification area (on unix) during build.]),
,enable_zenity=yes)
+AC_ARG_ENABLE(nsplugin,
+ AS_HELP_STRING([--disable-nsplugin],
+ [Do not build nsplugin extension for browser embedding.])
+)
+
AC_ARG_ENABLE(ccache,
AS_HELP_STRING([--disable-ccache],
[Do not try to use ccache automatically.
@@ -1313,7 +1318,7 @@ WITH_SYSTEM_MOZILLA=no)
AC_ARG_WITH(system-mozilla-headers,
AS_HELP_STRING([--with-system-mozilla-headers],
- [Use mozilla headers provided by system instead of bundled ones. Needed for
+ [Use mozilla headers provided by system instead of bundled ones. Used in
nsplugin]),,
[with_system_mozilla_headers="$with_system_headers"]
)
@@ -6010,6 +6015,23 @@ AC_SUBST(MOZILLA_HEADERS_CFLAGS)
AC_SUBST(SYSTEM_MOZILLA_HEADERS)
dnl ===================================================================
+dnl Check for nsplugin
+dnl ===================================================================
+AC_MSG_CHECKING([wether to build nsplugin extension])
+ENABLE_NSPLUGIN=NO
+if test "$enable_nsplugin" != "no"; then
+ if test "$enable_gtk" != "no"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_NSPLUGIN=YES
+ else
+ AC_MSG_RESULT([no, disabled gtk2])
+ fi
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_NSPLUGIN)
+
+dnl ===================================================================
dnl Check for system sane
dnl ===================================================================
AC_MSG_CHECKING([which sane header to use])