summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOliver Bolte <obo@openoffice.org>2009-03-06 09:33:41 +0000
committerOliver Bolte <obo@openoffice.org>2009-03-06 09:33:41 +0000
commitddd914a8e5e69d9e7579d1b55cff014a242bf46c (patch)
tree6e88180316971edfe28a67467fbba3208ad43c19 /configure.in
parentdbc028fb9b6b3cedf6ff78637b00752601dfea10 (diff)
CWS-TOOLING: integrate CWS movepsprint
2009-02-27 10:42:24 +0100 pl r268559 : #i99633# remove X11 build for mac 2009-02-26 16:38:01 +0100 pl r268535 : #i97898# move psprint to vcl: no more linking psprint 2009-02-26 16:36:35 +0100 pl r268534 : #i97898# move psprint to vcl: tentative os2 changes 2009-02-26 16:20:36 +0100 pl r268532 : #i97898# move psprint to vcl: make compile again, round 5 2009-02-26 15:53:12 +0100 pl r268530 : #i97898# psprint removed 2009-02-26 13:43:40 +0100 pl r268513 : #i97898# use proper X display in PrintFontManager::initialize 2009-02-26 12:39:05 +0100 pl r268496 : #i99633# remove unsused header 2009-02-25 19:12:54 +0100 pl r268467 : #i99633# get rid of special casing for the now discontinued Mac X11 port 2009-02-25 18:25:37 +0100 pl r268466 : #i97898# move psprint to vcl: make compile again, round 4 2009-02-25 17:38:55 +0100 pl r268458 : #i97898# move psprint to vcl: make compile again, round 3 2009-02-25 16:55:15 +0100 pl r268452 : #i97898# move psprint to vcl: remove psp lib from install set 2009-02-25 16:50:25 +0100 pl r268451 : #i97898# move psprint to vcl: make compile again, round 2 2009-02-25 16:10:50 +0100 pl r268448 : #i97898# move psprint to vcl: make compile again, round 1 2009-02-25 14:38:12 +0100 pl r268440 : #i97898# move psprint to vcl: remove references to psprint in solenv 2009-02-25 14:22:22 +0100 pl r268437 : #i97898# move psprint to vcl, first step: move in svn
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 20 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 5c97417dc40d..a446c4d8d6cf 100644
--- a/configure.in
+++ b/configure.in
@@ -4274,26 +4274,26 @@ AC_SUBST(SYSTEM_GENCMN)
dnl ===================================================================
dnl Checks for libraries.
dnl ===================================================================
-dnl Check for Mac OS X native GUI, which may be used instead of X11.
-dnl Check for a lack of --with-x option on Darwin. If it is missing, look to
-dnl see if we have the AppKit framework for building with Quartz graphics.
-
-if test "$_os" = "Darwin" -a "x$with_x" != "xyes" -a "x$x_includes" = "xNONE" -a "x$x_libraries" = "xNONE"; then
- dnl System is either Mac OS X or pure Darwin, and --with-x was not specified
- dnl Default to Aqua graphics if available.
- AC_MSG_CHECKING([for /System/Library/Frameworks/AppKit.framework])
- if test -d "/System/Library/Frameworks/AppKit.framework/"; then
- AC_MSG_RESULT([yes])
- x_includes="no_x_includes"
- x_libraries="no_x_libraries"
- dnl disable some things used on other Unix versions but not on the aqua build
- enable_gtk=no
- enable_cups=no
- ENABLE_CUPS=""
- AC_SUBST(ENABLE_CUPS)
+dnl Check for Mac OS X native GUI, which may is now required; the X11 build is no longer supported
+dnl See if we have the AppKit framework for building with Quartz graphics.
+
+if test "$_os" = "Darwin"; then
+ if test "x$with_x" = "xyes"; then
+ AC_MSG_ERROR([X11 build is no longer supported on MacOSX, please use the native aqua build])
else
- AC_MSG_RESULT([no])
- dnl Probably a pure Darwin system. Check for X11 below.
+ AC_MSG_CHECKING([for /System/Library/Frameworks/AppKit.framework])
+ if test -d "/System/Library/Frameworks/AppKit.framework/"; then
+ AC_MSG_RESULT([yes])
+ x_includes="no_x_includes"
+ x_libraries="no_x_libraries"
+ dnl disable some things used on other Unix versions but not on the aqua build
+ enable_gtk=no
+ enable_cups=no
+ ENABLE_CUPS=""
+ AC_SUBST(ENABLE_CUPS)
+ else
+ AC_MSG_ERROR([No AppKit.framewrok found])
+ fi
fi
fi
@@ -4301,7 +4301,7 @@ dnl ***************************************
dnl testing for X libraries and includes...
dnl ***************************************
if test "$_os" = "Darwin" -a "x$x_includes" = "xno_x_includes"; then
- echo "Do Nothing for _os = Darwin and x_includes = no_x_includes"
+ echo "Do Nothing for _os = Darwin"
dnl Mac OS X using Aqua graphics. Don't check for X11.
:
elif test "$_os" = "OS2" ; then