summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorIvo Hinkelmann <ihi@openoffice.org>2009-07-16 13:36:50 +0000
committerIvo Hinkelmann <ihi@openoffice.org>2009-07-16 13:36:50 +0000
commitf46813f452685d41abfa389a4634e02dffc2c4bd (patch)
treed0d822f255ea5b635d536b26710b162a2e789cd2 /configure.in
parent263df25c0b501a306f0d8111cf094c93ef1cff3a (diff)
CWS-TOOLING: integrate CWS tbo07
2009-07-15 12:50:18 +0200 tbo r274002 : #ii97838# fine tuning of text 2009-07-09 11:58:53 +0200 tbo r273855 : #i102592# add configur switch --enable-hids 2009-07-07 18:37:46 +0200 tbo r273812 : last fixes 2009-06-30 17:44:03 +0200 tbo r273527 : #i97838# dynamik hid.lst found 2009-06-30 12:53:57 +0200 tbo r273503 : #i100285# use other name of dialog 2009-06-25 18:56:33 +0200 tbo r273390 : CWS-TOOLING: rebase CWS tbo07 to trunk@272827 (milestone: DEV300:m50) 2009-06-25 15:31:23 +0200 tbo r273383 : #i100285# use other name of dialog 2009-06-25 14:15:33 +0200 tbo r273381 : #i100285# use other name of dialog + context problem with macos 2009-05-20 16:36:54 +0200 tbo r272140 : readme.txt fot the lost hid.lst file 2009-05-20 16:30:31 +0200 tbo r272139 : removal of hid.lst file 2009-05-20 16:28:26 +0200 tbo r272138 : corrections 2009-05-16 19:27:00 +0200 tbo r271982 : #i# copy hid.lst from OOo installation to global/hid 2009-04-21 13:36:36 +0200 tbo r271034 : #i101044# 2009-04-20 18:49:50 +0200 tbo r271009 : #i101044# 2009-04-20 18:47:35 +0200 tbo r271008 : #i100909#
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e46776bb2ad0..cc9a533e5553 100644
--- a/configure.in
+++ b/configure.in
@@ -61,6 +61,9 @@ AC_ARG_WITH(vba-package-format,
AC_ARG_ENABLE(pch,
[ --enable-pch EXPERIMENTAL: Enables precompiled header support for C++.
],,)
+AC_ARG_ENABLE(hids,
+[ --enable-hids Enables generation of HelpId lists.
+],,)
AC_ARG_ENABLE(mozilla,
[ --disable-mozilla OO.o usually includes a strangely hacked up mozilla
binary for your platform, to build without this
@@ -1492,6 +1495,19 @@ fi
AC_SUBST(ENABLE_PCH)
dnl ===================================================================
+dnl Set the NO_HIDS variable. (enable with --enable-hids)
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable hid list feature])
+if test -n "$enable_hids" && test "$enable_hids" != "no"; then
+ NO_HIDS=""
+ AC_MSG_RESULT([yes])
+else
+ NO_HIDS="TRUE"
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(NO_HIDS)
+
+dnl ===================================================================
dnl Search all the common names for GNU make
dnl ===================================================================
AC_MSG_CHECKING([for GNU make])