summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2011-07-04 13:52:55 +0100
committerCaolán McNamara <caolanm@redhat.com>2011-07-04 13:52:55 +0100
commit3ef130c949da9dd0d625a5cd84f43053e8e63577 (patch)
treef2454b96f172f425e3f38abdaf5b13e0f987d3db /configure.in
parent3039db3b6b0679f4cd874b346e4254a8546dba42 (diff)
for windows, iOS and Android only force cairo if librsvg required
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in96
1 files changed, 55 insertions, 41 deletions
diff --git a/configure.in b/configure.in
index cb80a220b6af..aa9bfb66b10f 100755
--- a/configure.in
+++ b/configure.in
@@ -6529,46 +6529,6 @@ fi
AC_SUBST(ENABLE_QUICKSTART_LIBPNG)
dnl ===================================================================
-dnl Test whether to build cairo or rely on the system version
-dnl ===================================================================
-
-SYSTEM_CAIRO=""
-
-AC_MSG_CHECKING([whether to use the system cairo])
-
-if test "$with_system_cairo" = yes -o \( "$with_system_libs" = yes -a "$with_system_cairo" != no \); then
- SYSTEM_CAIRO=YES
- AC_MSG_RESULT([yes])
-
- PKG_CHECK_MODULES( CAIRO, cairo >= 1.0.2 )
-
- if test "$with_system_xrender_headers" = "yes"; then
- AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
- AC_TRY_RUN([
-#include <X11/extensions/Xrender.h>
-
-int main(int argc, char **argv) {
-#ifdef PictStandardA8
- return 0;
-#else
- return 1;
-#endif
-}
- ],
- [AC_MSG_RESULT([yes])],
- [AC_MSG_ERROR([no, X headers too old.])]
- )
- fi
-else
- AC_MSG_RESULT([no])
- BUILD_TYPE="$BUILD_TYPE CAIRO"
-fi
-
-AC_SUBST(SYSTEM_CAIRO)
-AC_SUBST(CAIRO_CFLAGS)
-AC_SUBST(CAIRO_LIBS)
-
-dnl ===================================================================
dnl Check whether the GStreamer libraries are available.
dnl ===================================================================
@@ -8065,12 +8025,66 @@ AC_SUBST(LIBRSVG_LIBS)
AC_SUBST(SYSTEM_LIBRSVG)
dnl ===================================================================
+dnl Test whether to build cairo or rely on the system version
+dnl ===================================================================
+
+SYSTEM_CAIRO=""
+
+AC_MSG_CHECKING([whether to use the system cairo])
+
+if test "$with_system_cairo" = yes -o \( "$with_system_libs" = yes -a "$with_system_cairo" != no \); then
+ SYSTEM_CAIRO=YES
+ AC_MSG_RESULT([yes])
+
+ PKG_CHECK_MODULES( CAIRO, cairo >= 1.0.2 )
+
+ if test "$with_system_xrender_headers" = "yes"; then
+ AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
+ AC_TRY_RUN([
+#include <X11/extensions/Xrender.h>
+
+int main(int argc, char **argv) {
+#ifdef PictStandardA8
+ return 0;
+#else
+ return 1;
+#endif
+}
+ ],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_ERROR([no, X headers too old.])]
+ )
+ fi
+else
+ AC_MSG_RESULT([no])
+ dnl we only need cairo on windows if we
+ dnl building librsvg
+
+ dnl for iOS and Android cairo isn't
+ dnl buildable yet anyway.
+ if test "$ENABLE_LIBRSVG" != NO; then
+ case "$_os" in
+ WINNT|iOS|Android)
+ ;;
+ *)
+ BUILD_TYPE="$BUILD_TYPE CAIRO"
+ ;;
+ esac
+ fi
+fi
+
+AC_SUBST(SYSTEM_CAIRO)
+AC_SUBST(CAIRO_CFLAGS)
+AC_SUBST(CAIRO_LIBS)
+
+
+dnl ===================================================================
dnl Test whether to build gdk-pixbuf or rely on the system version
dnl ===================================================================
AC_MSG_CHECKING([whether to use the system gdk-pixbuf])
-dnl As long as the only thing we need gdk-pxbuf for is below
+dnl As long as the only thing we need gdk-pixbuf for is below
dnl librsvg, use the same --enable-librsvg (possibly implied
dnl by --with-system-libs) to override this.