summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@novell.com>2011-06-20 23:30:30 +0300
committerTor Lillqvist <tlillqvist@novell.com>2011-06-21 00:40:19 +0300
commit67e1946064ebc1b31111f09024622df735526997 (patch)
treea972b3fbea0ac19b3d43be6ea3707ed4e8166e27 /configure.in
parent7c6c7e1cfdc2a1a40bfda2b53ba0bdcf0871e7f7 (diff)
Disable ATL when compiling with MinGW
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 300e76212495..26456a3c3ac2 100755
--- a/configure.in
+++ b/configure.in
@@ -1829,15 +1829,22 @@ if test "$_os" = "WINNT"; then
AC_SUBST(DISABLE_ACTIVEX)
AC_MSG_CHECKING([whether to use ATL])
- if test "$enable_atl" = "yes" -o "$enable_atl" = "TRUE" -o "$enable_atl" = ""; then
+ if test "$enable_atl" = "yes" -o "$enable_atl" = "TRUE"; then
DISABLE_ATL=""
AC_MSG_RESULT([yes])
+ elif test "$enable_atl" = ""; then
+ if test "$WITH_MINGW" = "yes"; then
+ DISABLE_ATL="TRUE"
+ AC_MSG_RESULT([no])
+ else
+ DISABLE_ATL=""
+ AC_MSG_RESULT([yes])
+ fi
else
DISABLE_ATL="TRUE"
AC_MSG_RESULT([no])
fi
AC_SUBST(DISABLE_ATL)
-
fi
dnl Set the ENABLE_WERROR variable. (Activate --enable-werror)