summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mst@openoffice.org>2011-04-01 20:47:04 +0000
committerBjoern Michaelsen <bjoern.michaelsen@canonical.com>2011-06-17 09:36:09 +0200
commit8554a272d1c2b117adb6cf0a1da32ff415668b5a (patch)
tree664394cf7cd316e5cd3b4a8ea7804b6845948956 /configure.in
parent39d6eb1ac39e25b37035a74af625ab6e43c867c6 (diff)
gnumake4: configure.in: remove checks for obsolete Solaris 2.[67] [hg:e37d17b6d8d9]
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in101
1 files changed, 0 insertions, 101 deletions
diff --git a/configure.in b/configure.in
index 010704cb8694..3a8b466f1cfb 100644
--- a/configure.in
+++ b/configure.in
@@ -2300,107 +2300,6 @@ AC_LANG_POP([C++])
EXCEPTIONS="$exceptions_type"
AC_SUBST(EXCEPTIONS)
-dnl **************************************************************
-dnl Testing for required Solaris and SunStudio compiler patches...
-dnl **************************************************************
-dnl Check whether the OS is SunOS.
-if test "$_os" = "SunOS"; then
- _temp=`showrev -p | $AWK -F" " '{ print $2 }'`
- if test "$_os_release" = "7"; then
- dnl ***************
- dnl patch 106327-06
- dnl ***************
- AC_MSG_CHECKING([for patch 106327-06 or greater])
- _patch=`echo $_temp | $AWK '/106327-06/ { print "found" }'`
- _patch="false"
- for i in $_temp
- do
- _patch_major=`echo $i | $AWK -F"-" '{ print $1 }'`
- if test "$_patch_major" = "106327"; then
- _patch_rev=`echo $i | $AWK -F"-" '{ print $2 }'`
- if test "$_patch_rev" -ge "6"; then
- _patch="found"
- fi
- fi
- done
- if test "$_patch" = "found"; then
- AC_MSG_RESULT([found])
- else
- AC_MSG_WARN([patch 106327-06 not found, please install compiler patch 106327-06 or greater])
- echo "patch 106327-06 not found, please install compiler patch 106327-06 or greater" >> warn
- fi
- dnl ***************
- dnl patch 106950-11
- dnl ***************
- AC_MSG_CHECKING([for patch 106950-11 or greater])
- _patch=`echo $_temp | $AWK '/106950-11/ { print "found" }'`
- _patch="false"
- for i in $_temp
- do
- _patch_major=`echo $i | $AWK -F"-" '{ print $1 }'`
- if test "$_patch_major" = "106950"; then
- _patch_rev=`echo $i | $AWK -F"-" '{ print $2 }'`
- if test "$_patch_rev" -ge "11"; then
- _patch="found"
- fi
- fi
- done
- if test "$_patch" = "found"; then
- AC_MSG_RESULT([found])
- else
- AC_MSG_WARN([patch 106950-11 not found, please install linker patch 106950-11 or greater])
- echo "patch 106950-11 not found, please install linker patch 106950-11 or greater" >> warn
- fi
- else
- if test "$_os_release" = "6"; then
- dnl ***************
- dnl patch 105591-09
- dnl ***************
- AC_MSG_CHECKING([for patch 105591-09 or greater])
- _patch=`echo $_temp | $AWK '/105591-09/ { print "found" }'`
- _patch="false"
- for i in $_temp
- do
- _patch_major=`echo $i | $AWK -F"-" '{ print $1 }'`
- if test "$_patch_major" = "105591"; then
- _patch_rev=`echo $i | $AWK -F"-" '{ print $2 }'`
- if test "$_patch_rev" -ge "9"; then
- _patch="found"
- fi
- fi
- done
- if test "$_patch" = "found"; then
- AC_MSG_RESULT([found])
- else
- AC_MSG_WARN([patch 105591-09 not found, please install compiler patch 105591-09 or greater])
- echo "patch 105591-09 not found, please install compiler patch 105591-09 or greater" >> warn
- fi
- dnl ***************
- dnl patch 107733-08
- dnl ***************
- AC_MSG_CHECKING([for patch 107733-08 or greater])
- _patch=`echo $_temp | $AWK '/107733-08/ { print "found" }'`
- _patch="false"
- for i in $_temp
- do
- _patch_major=`echo $i | $AWK -F"-" '{ print $1 }'`
- if test "$_patch_major" = "107733"; then
- _patch_rev=`echo $i | $AWK -F"-" '{ print $2 }'`
- if test "$_patch_rev" -ge "8"; then
- _patch="found"
- fi
- fi
- done
- if test "$_patch" = "found"; then
- AC_MSG_RESULT([found])
- else
- AC_MSG_WARN([patch 107733-06 not found, please install linker patch 107733-08 or greater])
- echo "patch 107733-06 not found, please install linker patch 107733-08 or greater" >> warn
- fi
- fi
- fi
-fi
-
dnl ===================================================================
dnl Checks for what the default STL should be
dnl ===================================================================