summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-10-03 23:23:38 +0300
committerTor Lillqvist <tml@iki.fi>2012-10-03 23:32:05 +0300
commitca821bf466759347089dd1938162bcd5fdd3ae00 (patch)
treeef0747d023968cb605bca2a175127f48c80aba56 /configure.in
parent1d9803bacc4dc650a2ccf1c7a76e0e61759d1d27 (diff)
Don't try to make binaries that run on ancient OS when using current tools
For some reason the current Clang linker doesn't like that and misbehaves, Apple bug 12075544. It is unclear whether binaries built using a modern Xcode and SDK to run on 10.4 actually would run on 10.4 anyway. Change-Id: Id15da5eaa4bb95af9cf6d98a658c510f4a786185
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3b54b1a8b055..01960afa0257 100644
--- a/configure.in
+++ b/configure.in
@@ -2693,7 +2693,12 @@ if test "$_os" = "Darwin"; then
AC_MSG_RESULT([SDK $with_macosx_sdk at $MACOSX_SDK_PATH])
if test "$with_macosx_version_min_required" = ""; then
- with_macosx_version_min_required="10.4"
+ case $with_macosx_sdk in
+ 10.4|10.5)
+ with_macosx_version_min_required="10.4";;
+ *)
+ with_macosx_version_min_required="10.6";;
+ esac
fi
if test "$with_macosx_version_max_allowed" = ""; then