summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2011-09-25 19:38:33 -0400
committerPeter Foley <pefoley2@verizon.net>2011-10-01 18:34:46 -0400
commit0ce20f250af2a0adbaa37f45a13e8fe8f39eb4cc (patch)
tree312bb7f5d96d77b75e022bee35e36c3d3256ffcb /configure.in
parent74bd1f57b56918a3ef5f27aa2565397a4c6e85e1 (diff)
Don't generate config.status twice
The current configure script generates ooo.lst for the purpose of extracting the filename for the seamonkey tarball. This is unnecessary because ooo.lst.in contains the exact same filename. This patch moves the generation of ooo.lst next to the other generated files. This move uncovered that the code to set PREFIXDIR was depending on the AC_OUTPUT code to set prefix and exec_prefix to /usr/local or the value of --prefix rather than NONE. Because of this I added the prefix setting code from AC_OUTPUT to the code that sets PREFIXDIR.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index b141f65f9552..cb7cfcc40813 100644
--- a/configure.in
+++ b/configure.in
@@ -5709,8 +5709,6 @@ fi
AC_SUBST(WITH_LDAP)
AC_SUBST(WITH_OPENLDAP)
-AC_OUTPUT([ooo.lst])
-
dnl ===================================================================
dnl Check for system mozilla
dnl ===================================================================
@@ -5909,7 +5907,7 @@ if test "$BUILD_MOZAB" = "TRUE"; then
MOZILLA_VERSION=1.1.14
fi
MOZILLA_SOURCE_VERSION="seamonkey-${MOZILLA_VERSION}.source"
- MOZILLA_FETCH_FILE=`grep $MOZILLA_SOURCE_VERSION ooo.lst`
+ MOZILLA_FETCH_FILE=`grep $MOZILLA_SOURCE_VERSION ooo.lst.in`
AC_MSG_CHECKING([for Mozilla sources])
if test -z "$MOZILLA_FETCH_FILE"; then
AC_MSG_RESULT([not found])
@@ -9253,6 +9251,8 @@ AC_MSG_RESULT([$INSTALLDIRNAME])
AC_SUBST(INSTALLDIRNAME)
AC_MSG_CHECKING([for prefix])
+test "x$prefix" = xNONE && prefix=$ac_default_prefix
+test "x$exec_prefix" = xNONE && exec_prefix=$prefix
PREFIXDIR="$prefix"
AC_MSG_RESULT([$PREFIXDIR])
AC_SUBST(PREFIXDIR)
@@ -9492,7 +9492,8 @@ else
echo > set_soenv.last
fi
-AC_OUTPUT([set_soenv Makefile bin/repo-list desktop/scripts/soffice.sh])
+AC_CONFIG_FILES([ooo.lst set_soenv Makefile bin/repo-list desktop/scripts/soffice.sh])
+AC_OUTPUT
# make sure this is executable
chmod +x desktop/scripts/soffice.sh