summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-09-17 12:56:18 +0200
committerTomas Chvatal <tchvatal@suse.cz>2011-09-17 12:56:18 +0200
commitd0c339682a9c1e3df5d80e899ff2248bfe594b52 (patch)
tree6e860d4f24f59b26189efd88bda69d0616345331 /configure.in
parent7b502808dba8a4790a94182bf9835ba702f6f81b (diff)
Fix whitespace in last commit, add safeguards for the with-theme values.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a99ddb032f74..c3cff3e03d6e 100755
--- a/configure.in
+++ b/configure.in
@@ -7748,16 +7748,20 @@ dnl ===================================================================
AC_MSG_CHECKING([which themes to include])
# if none given, use all available themes
AS_IF([test "x$with_theme" = "x" -o "x$with_theme" = "xyes"], [
- with_theme="default crystal hicontrast oxygen tango"
+ with_theme="default crystal hicontrast oxygen tango"
])
WITH_THEMES=""
for theme in $with_theme; do
+ AS_CASE([$theme],
+ [default|crystal|hicontrast|oxygen|tango], [],
+ [AC_MSG_ERROR([Unknown value for --with-themes: $theme])]
+ )
WITH_THEMES="$WITH_THEMES $theme"
SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[:lower:]' '[:upper:]'`"
done
AC_MSG_RESULT([$WITH_THEMES])
-AC_SUBST(WITH_THEMES)
+AC_SUBST([WITH_THEMES])
dnl ===================================================================
dnl Test whether to integrate helppacks into the product's installer