summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2010-11-10 14:55:56 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2010-11-10 14:55:56 +0100
commitc6c1673683867280b6ca0ef92da3040f2277ab41 (patch)
tree81c7b08542dd8147852dd1f8b64f47ddaf011033 /configure.in
parent813eb5d9a9f2178e514022a5c5de228bfcfb3bab (diff)
Pull some common options as defaults and only change them if needed
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 10 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index e477d2c3852d..318d77f25361 100644
--- a/configure.in
+++ b/configure.in
@@ -1544,14 +1544,16 @@ dnl The following is a list of supported systems.
dnl Sequential to keep the logic very simple
dnl These values may be checked and reset later.
dnl ===================================================================
+#defaults unless the os test overrides this:
+test_cairo=yes
+test_randr=yes
+
case "$build_os" in
solaris*)
test_gtk=yes
- test_cairo=yes
build_gstreamer=yes
test_kde=yes
test_cups=yes
- test_randr=yes
test_freetype=yes
_os=SunOS
AC_PATH_PROG( GNUTAR, gtar,,$PATH:/usr/sfw/bin)
@@ -1581,30 +1583,29 @@ case "$build_os" in
;;
linux-gnu*|k*bsd*-gnu*)
test_gtk=yes
- test_cairo=yes
build_gstreamer=yes
test_kde=yes
test_kde4=yes
test_cups=yes
- test_randr=yes
test_freetype=yes
test_unix_quickstarter=yes
_os=Linux
;;
gnu)
+ test_randr=no
+ test_cairo=no
test_cups=no
_os=GNU
;;
cygwin*) # Windows
test_cups=no
- test_cairo=yes
+ test_randr=no
test_freetype=no
_os=WINNT
;;
darwin*) # Mac OS X
test_cups=yes
test_gtk=yes
- test_cairo=yes
test_randr=no
test_freetype=no
_os=Darwin
@@ -1615,21 +1616,19 @@ case "$build_os" in
fi
;;
os2*)
- test_x=no
test_cups=no
test_randr=no
test_gtk=no
+ test_cairo=no
test_freetype=no
_os=OS2
;;
freebsd*)
test_gtk=yes
- test_cairo=yes
build_gstreamer=yes
test_kde=yes
test_kde4=yes
test_cups=yes
- test_randr=yes
test_freetype=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
if test -n "$with_os_version"; then
@@ -1654,17 +1653,16 @@ case "$build_os" in
;;
osf)
test_cups=no
+ test_cairo=no
test_randr=no
_os=OSF1
;;
*netbsd*)
test_gtk=yes
- test_cairo=yes
build_gstreamer=yes
test_kde=yes
test_kde4=yes
test_cups=yes
- test_randr=yes
test_freetype=yes
PTHREAD_CFLAGS="-pthread"
PTHREAD_LIBS="-pthread -lpthread"
@@ -1673,18 +1671,16 @@ case "$build_os" in
aix*)
test_cups=no
test_randr=no
+ test_cairo=no
test_freetype=yes
PTHREAD_LIBS=-pthread
_os=AIX
;;
openbsd*)
- test_x=yes
test_gtk=yes
- build_cairo=yes
test_kde=yes
test_cups=yes
test_freetype=yes
- test_randr=yes
PTHREAD_CFLAGS="-pthread -D_THREAD_SAFE"
PTHREAD_LIBS="-pthread"
_os=OpenBSD