summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoseph Powers <jpowers27@cox.net>2011-07-26 20:13:32 -0700
committerJoseph Powers <jpowers27@cox.net>2011-07-26 20:13:42 -0700
commit6f1d90accb2f76def6c2c83a97aa317303595e49 (patch)
tree232dfe188eee2881e5a943e89db609812b246752 /configure.in
parentb5e6d0a679ec3f80cae781c93fe7d728dd53b58e (diff)
LIBXML & LIBXSLT should point to the correct SDK (Mac OS X)
Also, the 10.7 SDK is named 10.7 and not 10.6. (copy/paste issue)
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e5632cda4d54..a67a61419902 100755
--- a/configure.in
+++ b/configure.in
@@ -1735,8 +1735,8 @@ if test "$_os" = "Darwin" ; then
echo "Building with a SDK > 10.4 is experimental" >> warn
;;
10.7)
- MACOSX_SDK_PATH="/Developer/SDKs/MacOSX10.6.sdk"
- macosx_sdk_value="1060"
+ MACOSX_SDK_PATH="/Developer/SDKs/MacOSX10.7.sdk"
+ macosx_sdk_value="1070"
AC_MSG_WARN([Building with a SDK > 10.4 is experimental])
echo "Building with a SDK > 10.4 is experimental" >> warn
;;
@@ -4443,7 +4443,7 @@ if test -n "$with_system_libxslt" -o -n "$with_system_libs" -o \
SYSTEM_LIBXSLT=YES
if test "$_os" = "Darwin"; then
dnl make sure to use SDK path
- LIBXSLT_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/usr/include/libxml2"
+ LIBXSLT_CFLAGS="-I$MACOSX_SDK_PATH/usr/include/libxml2"
dnl omit -L/usr/lib
LIBXSLT_LIBS="-lxslt -lxml2 -lz -lpthread -liconv -lm"
else
@@ -4483,7 +4483,7 @@ if test -n "$with_system_libxml" -o -n "$with_system_libs" -o \
SYSTEM_LIBXML=YES
if test "$_os" = "Darwin"; then
dnl make sure to use SDK path
- LIBXML_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/usr/include/libxml2"
+ LIBXML_CFLAGS="-I$MACOSX_SDK_PATH/usr/include/libxml2"
dnl omit -L/usr/lib
LIBXML_LIBS="-lxml2 -lz -lpthread -liconv -lm"
elif test $_os = iOS; then