summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2011-05-30 00:29:45 +0300
committerTor Lillqvist <tml@iki.fi>2011-05-30 00:30:00 +0300
commit2aa5e88b68169293a55f15c69ce92711faed04fd (patch)
treed3c26bf38130df4ebd9ef679d111f589ea735164 /configure.in
parent4e85b56b3baf14a0a23d57e218acd57823913e41 (diff)
Simplify the new checks for when to use a system library by default
Just list the OSes for which there is no "system" installed GLib etc in one case in the case statement. Add iOS to the set.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in44
1 files changed, 8 insertions, 36 deletions
diff --git a/configure.in b/configure.in
index 6a94d9bfcb03..bc6d4bad26a8 100755
--- a/configure.in
+++ b/configure.in
@@ -7972,11 +7972,7 @@ if test $SYSTEM_LIBRSVG = YES; then
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_GDKPIXBUF=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_GDKPIXBUF=NO
AC_MSG_RESULT([no])
;;
@@ -8003,11 +7999,7 @@ if test $SYSTEM_LIBRSVG = YES; then
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_GLIB=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_GLIB=NO
AC_MSG_RESULT([no])
;;
@@ -8031,11 +8023,7 @@ if test "$with_system_gettext" = yes -o \( "$with_system_libs" = yes -a "$with_s
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_GETTEXT=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_GETTEXT=NO
AC_MSG_RESULT([no])
;;
@@ -8062,11 +8050,7 @@ if test $SYSTEM_LIBRSVG = YES; then
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_LIBCROCO=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_LIBCROCO=NO
AC_MSG_RESULT([no])
;;
@@ -8093,11 +8077,7 @@ if test $SYSTEM_LIBRSVG = YES; then
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_PANGO=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_PANGO=NO
AC_MSG_RESULT([no])
;;
@@ -8124,7 +8104,7 @@ if test $SYSTEM_LIBRSVG = YES; then
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
+ WINNT|Darwin|iOS)
SYSTEM_LIBGSF=NO
AC_MSG_RESULT([no])
;;
@@ -8151,11 +8131,7 @@ if test "$with_system_libpng" = yes -o \( "$with_system_libs" = yes -a "$with_sy
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_LIBPNG=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_LIBPNG=NO
AC_MSG_RESULT([no])
;;
@@ -8181,11 +8157,7 @@ if test "$SYSTEM_JPEG" == "YES"; then
AC_MSG_RESULT([yes])
else
case "$_os" in
- WINNT*)
- SYSTEM_LIBJPEG=NO
- AC_MSG_RESULT([no])
- ;;
- Darwin*)
+ WINNT|Darwin|iOS)
SYSTEM_LIBJPEG=NO
AC_MSG_RESULT([no])
;;