summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@novell.com>2011-05-28 13:05:28 +0300
committerTor Lillqvist <tlillqvist@novell.com>2011-05-28 13:05:31 +0300
commit9108788fc95f01b032b1cf6773b4d74537e5c2e1 (patch)
treeb55280377ceeecc893b30dcc35c2db8c8f184bad /configure.in
parentf180df3a277b1d12f09cbade5bad4281e9d5e2af (diff)
We always need cairo now with librsvg always being used
At least, I think we do... So simplify the tests for it.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in68
1 files changed, 27 insertions, 41 deletions
diff --git a/configure.in b/configure.in
index b600210aba8e..14c4e74d5bee 100755
--- a/configure.in
+++ b/configure.in
@@ -272,12 +272,6 @@ AC_ARG_ENABLE(systray,
[Determines whether to build the systray quickstarter.]),
,enable_systray=yes)
-AC_ARG_ENABLE(cairo,
- AS_HELP_STRING([--disable-cairo],
- [Determines whether to use Cairo library on platforms where Cairo is
- available.]),
-,enable_cairo=yes)
-
AC_ARG_ENABLE(librsvg,
[ --enable-librsvg Determines whether to use librsvg library on
platforms where librsvg is available.
@@ -1426,7 +1420,6 @@ dnl Sequential to keep the logic very simple
dnl These values may be checked and reset later.
dnl ===================================================================
#defaults unless the os test overrides this:
-test_cairo=yes
test_randr=yes
test_cups=yes
test_fontconfig=yes
@@ -1477,7 +1470,6 @@ case "$host_os" in
;;
gnu)
test_randr=no
- test_cairo=no
test_cups=no
_os=GNU
;;
@@ -1502,7 +1494,6 @@ case "$host_os" in
test_randr=no
test_librsvg=no
test_freetype=no
- test_cairo=no
test_fontconfig=no
_os=WINNT
# Confusingly, if the host OS matches "mingw32*", that means
@@ -1521,7 +1512,6 @@ case "$host_os" in
test_randr=no
test_freetype=no
test_fontconfig=no
- test_cairo=no
if test "$host_cpu" = "arm"; then
_os=iOS
test_gtk=no
@@ -1575,7 +1565,6 @@ case "$host_os" in
aix*)
test_cups=no
test_randr=no
- test_cairo=no
test_freetype=yes
PTHREAD_LIBS=-pthread
_os=AIX
@@ -1599,7 +1588,6 @@ case "$host_os" in
;;
androideabi*)
build_gstreamer=no
- test_cairo=no
test_cups=no
test_fontconfig=no
test_freetype=no
@@ -6498,32 +6486,31 @@ fi
AC_SUBST(ENABLE_QUICKSTART_LIBPNG)
dnl ===================================================================
-dnl Check whether the Cairo libraries are available.
+dnl Test whether to build cairo or rely on the system version
dnl ===================================================================
-ENABLE_CAIRO=""
+dnl Now with librsvg we always need cairo (?), so hardcode ENABLE_CAIRO to TRUE
+dnl Eventually should bin conditionals on ENABLE_CAIRO.
+ENABLE_CAIRO="TRUE"
+
BUILD_PIXMAN=""
SYSTEM_CAIRO=""
-if test "$test_cairo" = "yes"; then
+AC_MSG_CHECKING([whether to use the system cairo])
- AC_MSG_CHECKING([whether to use cairo])
- if test "x$enable_cairo" != "xno" ; then
- ENABLE_CAIRO="TRUE"
+if test "$with_system_cairo" = yes -o \( "$with_system_libs" = yes -a "$with_system_cairo" != no \); then
+ SYSTEM_CAIRO=YES
AC_MSG_RESULT([yes])
- AC_MSG_CHECKING([which cairo to use])
- if test -n "$with_system_cairo" -o -n "$with_system_libs" && \
- test "$with_system_cairo" != "no"; then
- AC_MSG_RESULT([external])
- SYSTEM_CAIRO=YES
-
- PKG_CHECK_MODULES( CAIRO, cairo >= 1.0.2 )
- if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$ENABLE_FONTCONFIG" != "TRUE" ; then
- AC_MSG_ERROR([Cairo library requires fontconfig.])
- fi
- if test "$with_system_xrender_headers" = "yes"; then
- AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
- AC_TRY_RUN([
+
+ PKG_CHECK_MODULES( CAIRO, cairo >= 1.0.2 )
+
+ if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$ENABLE_FONTCONFIG" != "TRUE" ; then
+ AC_MSG_ERROR([Cairo library requires fontconfig.])
+ fi
+
+ if test "$with_system_xrender_headers" = "yes"; then
+ AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
+ AC_TRY_RUN([
#include <X11/extensions/Xrender.h>
int main(int argc, char **argv) {
@@ -6533,16 +6520,15 @@ int main(int argc, char **argv) {
return 1;
#endif
}
- ], [AC_MSG_RESULT([yes])], [AC_MSG_ERROR([no, X headers too old.])])
- fi
- else
- BUILD_TYPE="$BUILD_TYPE CAIRO"
- BUILD_PIXMAN=YES
- AC_MSG_RESULT([internal])
- fi
- else
- AC_MSG_RESULT([no])
+ ],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_ERROR([no, X headers too old.])]
+ )
fi
+else
+ AC_MSG_RESULT([no])
+ BUILD_TYPE="$BUILD_TYPE CAIRO"
+ BUILD_PIXMAN=YES
fi
AC_SUBST(ENABLE_CAIRO)
@@ -7980,7 +7966,7 @@ else
SYSTEM_LIBRSVG=NO
AC_MSG_RESULT([no])
;;
- *)
+ *)
SYSTEM_LIBRSVG=YES
AC_MSG_RESULT([yes])
;;