summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFernando Governatore <affqlixo@gmail.com>2012-02-25 15:22:08 -0200
committerMichael Meeks <michael.meeks@suse.com>2012-02-27 21:31:49 +0000
commit207dbaaf83a9955f0b02978551340080ddac10cc (patch)
tree24ad470ecf72c948a6adc2358a002d0cb6f9ccc1 /configure.in
parentfa5e41067bc15c38dcc6c0c6fb327adad0444774 (diff)
fix icecc compile in ubuntu
In ubuntu the GCC_HOME of icecc is in /usr/lib/icecc
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fe35ab3ded03..8271431648e2 100644
--- a/configure.in
+++ b/configure.in
@@ -2167,7 +2167,11 @@ GCC_HOME_SET="true"
AC_MSG_CHECKING([gcc home])
if test -z "$with_gcc_home"; then
if test "$enable_icecream" = "yes" ; then
- GCC_HOME="/opt/icecream"
+ if test -d "/usr/lib/icecc/" ; then
+ GCC_HOME="/usr/lib/icecc/"
+ else
+ GCC_HOME="/opt/icecream/"
+ fi
else
GCC_HOME=`which gcc | $SED -e s,/bin/gcc,,`
GCC_HOME_SET="false"