summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-02-17 09:50:36 +0100
committerDavid Tardon <dtardon@redhat.com>2012-02-17 15:53:57 +0100
commit50c5c10ac3cb03c10a25cf07d75f6cce75571ec0 (patch)
treeae07ecf714a1eb1eb8f18517d9227a8991eedaa6 /configure.in
parent2afa9317cd2a137154c1ea06a2449308d26db8ea (diff)
allow using system db in cross-compilation build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5d50dbb58be8..bbb36e276c48 100644
--- a/configure.in
+++ b/configure.in
@@ -1941,6 +1941,10 @@ AC_ARG_WITH(system-cppunit-for-build,
AS_HELP_STRING([--with-system-cppunit-for-build],
[Use cppunit/libxslt already on system for build tools (cross-compilation only).]))
+AC_ARG_WITH(system-db-for-build,
+ AS_HELP_STRING([--with-system-db-for-build],
+ [Use db/libxslt already on system for build tools (cross-compilation only).]))
+
AC_ARG_WITH(system-libxml-for-build,
AS_HELP_STRING([--with-system-libxml-for-build],
[Use libxml/libxslt already on system for build tools (cross-compilation only).]))
@@ -3181,6 +3185,7 @@ if test "$cross_compiling" = "yes"; then
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test -n "$with_system_boost_for_build" && sub_conf_opts="$sub_conf_opts --with-system-boost"
test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit"
+ test -n "$with_system_db_for_build" && sub_conf_opts="$sub_conf_opts --with-system-db"
test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
./configure \
--disable-mozilla \