summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2011-10-03 13:14:28 +0300
committerTor Lillqvist <tlillqvist@suse.com>2011-10-03 13:23:12 +0300
commit0dd1e3b1240e4d5a2c9ac6de0348658918e012a8 (patch)
treeac0dee539258dc4f699dfc6d2fbff94fe02b5e50 /configure.in
parent296abad4fadd87b6b38074b504e40f1532c65969 (diff)
Don't bother with libcmis on Windows for now
It obviously doesn't build as autoconf and libtool have little clue about MSVC. Thus make the cmis UCP Unix-only as well. Looking forward to coming gbuildification of more 3rd-party modules.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 49b7185929a2..a62863454004 100644
--- a/configure.in
+++ b/configure.in
@@ -4627,10 +4627,13 @@ if test -n "$with_system_libcmis" -a "$with_system_libcmis" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_LIBCMIS=YES
PKG_CHECK_MODULES( LIBCMIS, libcmis-0.2 )
-else
+elif test $_os != WINNT; then
AC_MSG_RESULT([internal])
SYSTEM_LIBCMIS=NO
BUILD_TYPE="$BUILD_TYPE LIBCMIS"
+else
+ AC_MSG_RESULT([none])
+ SYSTEM_LIBCMIS=YES
fi
AC_SUBST(SYSTEM_LIBCMIS)
AC_SUBST(LIBCMIS_CFLAGS)