summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2011-09-28 20:40:07 +0000
committerRene Engelhard <rene@debian.org>2011-09-28 22:42:22 +0200
commit0f862a7432737d16056270cf8fbc29478f988f7d (patch)
tree4b039994877395c7dd6acd60e78a0847273b0af8 /configure.in
parent0a56437e9ce6a228643e2831fe4877e8597cfa6b (diff)
make configure check for cpp/poppler-version.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3224852b4119..d71eb22669c6 100644
--- a/configure.in
+++ b/configure.in
@@ -7034,6 +7034,16 @@ if test "x$enable_ext_pdfimport" != "xno" -a "x$enable_extension_integration" !=
AC_MSG_RESULT([external])
SYSTEM_POPPLER=YES
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
+ AC_LANG_PUSH([C++])
+ save_CXXFLAGS=$CXXFLAGS
+ save_CPPFLAGS=$CPPFLAGS
+ CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
+ AC_CHECK_HEADER([cpp/poppler-version.h], [],
+ [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
+ CXXFLAGS=$save_CXXFLAGS
+ CPPFLAGS=$save_CPPFLAGS
+ AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])
SYSTEM_POPPLER=NO