summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBjoern Michaelsen <bjoern.michaelsen@canonical.com>2011-09-26 21:22:07 +0200
committerBjoern Michaelsen <bjoern.michaelsen@canonical.com>2011-09-26 21:26:20 +0200
commit3136120275834b17f9ff628273cee169d171566e (patch)
tree3cd12f4950c33584fc0584cfa009d1c332813d7a /configure.in
parent226a5ddda17e4b9c0744b7e3f5203f46a4ba289e (diff)
partially revert 6985b28d533c1324896a1647304499c23e553239 as it breaks the whole idea of testing for bug 20033
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index f1a38b7f8729..6a983967c05f 100644
--- a/configure.in
+++ b/configure.in
@@ -2552,11 +2552,11 @@ A := \$(wildcard *.a)
.PHONY: all
all: \$(A:.a=.b)
- @echo survived bug20033.
+ @echo survived bug20033. #dont kill these tabs, you will break the Makefile!!!!
.PHONY: setup
setup:
- @touch 1.a 2.a 3.a 4.a 5.a 6.a
+ @touch 1.a 2.a 3.a 4.a 5.a 6.a
define d1
@echo lala \$(1)
@@ -2569,9 +2569,9 @@ define d2
endef
%.b : %.a
- \$(eval CHECKSUM := \$(word 1,\$(shell cat \$^ | sha1sum))) \$(if \$(wildcard \$(CACHEDIR)/\$(CHECKSUM)),\
- \$(call d1,\$(CHECKSUM)),\
- \$(call d2,\$(CHECKSUM)))
+ \$(eval CHECKSUM := \$(word 1,\$(shell cat \$^ | sha1sum))) \$(if \$(wildcard \$(CACHEDIR)/\$(CHECKSUM)),\
+ \$(call d1,\$(CHECKSUM)),\
+ \$(call d2,\$(CHECKSUM)))
EOF
if test -z "`(cd $TESTGMAKEBUG20033 && $GNUMAKE setup && $GNUMAKE -j)|grep survived`"; then
no_parallelism_make="YES"