summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2011-09-27 09:46:00 +0300
committerTor Lillqvist <tml@iki.fi>2011-09-27 10:00:47 +0300
commit47d7d1e987e1caa030c7623767d9dfe3d85eb924 (patch)
tree2cd856f5ebc2096a359c5c26745637817529bdcc /configure.in
parent36e4ca307cb9f282f72231ae05c210469c31dfc2 (diff)
Enforce use of internal Python for MacOSX 10.[45] only, as apparently is the intent
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6a983967c05f..791b69346e73 100644
--- a/configure.in
+++ b/configure.in
@@ -4771,8 +4771,8 @@ no|disable)
dnl MinGW cross-compilation setups.)
AC_MSG_RESULT([internal])
enable_python=internal
- elif test $_os = Darwin; then
- AC_MSG_RESULT([internal, neither 10.4's nor 10.5's Python is compatible with Python3-ified pyuno])
+ elif test $_os = Darwin -a \( "$with_macosx_version_min_required" = 10.4 -o "$with_macosx_version_min_required" = 10.5 \); then
+ AC_MSG_RESULT([internal, the Python in Mac OS X $with_macosx_version_min_required is incompatible with Python3-ified pyuno])
enable_python=internal
else
AC_MSG_RESULT([checking below])
@@ -4783,6 +4783,9 @@ internal)
AC_MSG_RESULT([internal])
;;
system)
+ if test $_os = Darwin -a \( "$with_macosx_version_min_required" = 10.4 -o "$with_macosx_version_min_required" = 10.5 \); then
+ AC_MSG_ERROR([Cannot use "system" Python, the Python in Mac OS X $with_macosx_version_min_required is incompatible with Python3-ified pyuno])
+ fi
AC_MSG_RESULT([system])
;;
*)