summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-09-20 10:37:10 +0300
committerTor Lillqvist <tml@iki.fi>2012-09-20 10:37:16 +0300
commit288d4bf31399f474aadcd16b9a800aade0741aa2 (patch)
tree280a4f78dcba13b7377b8c140dcf2bb2c17c1614 /configure.in
parent90fc5593a44f41489719bc882db21813416f80da (diff)
Move -isysroot from gb_CFLAGS/gb_CXXFLAGS to CC/CXX
That is a much better place for it. The gb_C(XX)FLAGS don't get passed on to "external" modules, so they should not contain flags that are essential for the compilation to work at all. I think. At least for me, in my MacOSX SDK 10.4 -based build tree, using Xcode 3 installed in /Xcode3, on OS X 10.8, the -isysroot is essential for liborcus to compile. Change-Id: I1f11c690585e4ba512eb87d2fddf11872b91dd57
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index c719859f4589..10106724ee35 100644
--- a/configure.in
+++ b/configure.in
@@ -2740,19 +2740,19 @@ if test "$_os" = "Darwin"; then
AC_MSG_ERROR([Cannot guess gcc location for this SDK])
;;
esac
- CC="${gccprefix}gcc-4.0 -mmacosx-version-min=$with_macosx_version_min_required"
- CXX="${gccprefix}g++-4.0 -mmacosx-version-min=$with_macosx_version_min_required"
+ CC="${gccprefix}gcc-4.0 -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
+ CXX="${gccprefix}g++-4.0 -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
;;
10.6)
# Is similar logic as above needed? Is it likely somebody
# has both an older Xcode with the 10.6 SDK and a current
# Xcode?
- CC="gcc-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required"
- CXX="g++-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required"
+ CC="gcc-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
+ CXX="g++-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
;;
10.7|10.8)
- CC="`xcrun -find clang` $bitness -mmacosx-version-min=$with_macosx_version_min_required"
- CXX="`xcrun -find clang++` $bitness -mmacosx-version-min=$with_macosx_version_min_required"
+ CC="`xcrun -find clang` $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
+ CXX="`xcrun -find clang++` $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
;;
esac
AC_MSG_RESULT([$CC and $CXX])