summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-01-19 01:52:10 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-02-05 19:34:03 -0600
commit4a9526d59bb3f207c74a757b338b7950f604d450 (patch)
treeccda4362b07134955eb42ef4749a8822e46c8a15 /configure.in
parent827088562334fd811fb27d488fadde495f0f3e44 (diff)
migrate WITH_POOR_HELP_LOCALIZATIONS out of set_soenv
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1447dbd3090f..2dac8593ce68 100644
--- a/configure.in
+++ b/configure.in
@@ -10230,6 +10230,20 @@ AC_SUBST(WITH_LANG)
AC_SUBST(WITH_LANG_LIST)
AC_SUBST(GIT_REPO_NAMES)
+
+PathFormat "$SRC_ROOT/translations"
+L10N_MODULE="$formatted_path"
+WITH_POOR_HELP_LOCALIZATIONS=
+if test -d "./translations" ; then
+ for l in `ls -1 translations/source` ; do
+ if test ! -d translations/source/$l/helpcontent2 ; then
+ WITH_POOR_HELP_LOCALIZATIONS="$WITH_POOR_HELP_LOCALIZATIONS $l"
+ fi
+ done
+fi
+AC_SUBST(L10N_MODULE)
+AC_SUBST(WITH_POOR_HELP_LOCALIZATIONS)
+
dnl git-new-workdir
dnl ===================================================================
if test -n "${GIT_LINK_SRC}"; then