summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2012-02-10 12:32:40 +0000
committerCaolán McNamara <caolanm@redhat.com>2012-02-10 14:20:52 +0000
commit21040f22886e842847f18e9e4a2721a1845ea74d (patch)
treea11f1d9090fa679d6b49a6c68e1ccd7b5746bc68 /configure.in
parent0b584c9442922aa0c15fd56a68c2852ff8a24f82 (diff)
hack around sdk installer breakage
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7910b2b0299c..edc3e992825a 100644
--- a/configure.in
+++ b/configure.in
@@ -7711,6 +7711,16 @@ if test "$_os" = "WINNT"; then
if test -n "$WINDOWS_SDK_HOME"; then
WINDOWS_SDK_HOME=`cygpath -d "$WINDOWS_SDK_HOME"`
WINDOWS_SDK_HOME=`cygpath -u "$WINDOWS_SDK_HOME"`
+
+ #If this sdk is incomplete, lets see if the one
+ #recommended to be installed is available
+ if test ! -x "$WINDOWS_SDK_HOME/bin/msiinfo.exe"; then
+ WINDOWS_SDK7_HOME=`cat "/proc/registry/HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/Windows/v7.1/InstallationFolder" 2> /dev/null | tr '\000' '\n' | head -n 1`
+ if test -n "$WINDOWS_SDK7_HOME"; then
+ WINDOWS_SDK_HOME=`cygpath -d "$WINDOWS_SDK7_HOME"`
+ WINDOWS_SDK_HOME=`cygpath -u "$WINDOWS_SDK_HOME"`
+ fi
+ fi
fi
else
WINDOWS_SDK_HOME=`cygpath -u "$with_windows_sdk_home"`