summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-01-18 15:32:46 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-02-05 19:34:01 -0600
commitc251231c749ba1f90878cadc3491f690898f1f33 (patch)
tree942eb75f6a7bf441c56ecb0161f3bad8de8ae998 /configure.in
parentda8a424f9a62e9f164ef3a64fc5002db3823fe00 (diff)
add function to deal with native windows path variables
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be0848d3293c..5f81ea1c1bb4 100644
--- a/configure.in
+++ b/configure.in
@@ -40,6 +40,14 @@ PathFormat()
fi
}
+WinPath()
+{
+ formatted_path="$1"
+ if test "$build_os" = "cygwin" ; then
+ formatted_path=`cygpath -d "$formatted_path"`
+ fi
+}
+
if test -n "$SOLARENV" ; then
AC_MSG_ERROR([You have sourced Env.Host.sh in this shell. This may lead to trouble, please run in a fresh (login) shell.])
fi