summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-01-05 17:36:21 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-01-05 17:53:03 +0200
commit01d7c6a24b7a8244a3ae5816e39d3358242a35ea (patch)
tree0ac66312764ae17ef61030e1bfbbc04d2ff7b03e /configure.in
parentc8bab278bb2ee9b27b5e8181100cb23dcf5a975c (diff)
Set FONTCONFIG_LIBS and FREETYPE_LIBS for the internal case (for Android)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index b7b255abe95e..2683a329f8a3 100644
--- a/configure.in
+++ b/configure.in
@@ -3115,13 +3115,15 @@ if test "$test_cups" = "yes"; then
fi
-# check for fontconfig support
-AC_MSG_CHECKING([whether we need fontconfig])
+# fontconfig checks
if test "z$test_fontconfig" = "zyes"; then
- AC_MSG_RESULT([yes])
PKG_CHECK_MODULES([FONTCONFIG], [fontconfig >= 2.2.0])
else
- AC_MSG_RESULT([no])
+ case "$BUILD_TYPE" in
+ *FONTCONFIG*)
+ FONTCONFIG_LIBS="-lfontconfig"
+ ;;
+ esac
fi
AC_SUBST(FONTCONFIG_CFLAGS)
AC_SUBST(FONTCONFIG_LIBS)
@@ -5451,6 +5453,12 @@ dnl ===================================================================
if test "$test_freetype" = "yes"; then
AC_MSG_CHECKING([whether freetype is available])
PKG_CHECK_MODULES( FREETYPE, freetype2 >= 2.0 )
+else
+ case "$BUILD_TYPE" in
+ *FREETYPE*)
+ FREETYPE_LIBS="-lfreetype"
+ ;;
+ esac
fi
AC_SUBST(FREETYPE_CFLAGS)
AC_SUBST(FREETYPE_LIBS)