summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-02-06 12:05:04 +0200
committerTor Lillqvist <tml@iki.fi>2012-02-06 16:57:39 +0200
commit3a8a275d74ea8e2147e59d2578539b6bbc60927b (patch)
tree6b45f003ba4b496dac08566a5865d749f69c8b0d /configure.in
parent66e4c5851b7ef27d375e2bdb482e723f6e0ce1f0 (diff)
Clarify and simplify a bit as we don't have any X11 option on Mac OS X anyway
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 3 insertions, 28 deletions
diff --git a/configure.in b/configure.in
index eeda25e7ccc3..33facd89cf4a 100644
--- a/configure.in
+++ b/configure.in
@@ -2714,6 +2714,7 @@ cygwin*)
darwin*)
COM=GCC
GUI=UNX
+ # Not sure if "Aqua" is the right term to use?
GUIBASE="aqua"
OS=MACOSX
P_SEP=:
@@ -7246,30 +7247,7 @@ AC_SUBST(SYSTEM_SAMPLEICC)
AC_SUBST(SAMPLEICC_LIBS)
AC_SUBST(SAMPLEICC_CFLAGS)
-dnl ===================================================================
-dnl Checks for libraries.
-dnl ===================================================================
-dnl Check for Mac OS X native GUI, which may is now required; the X11 build is no longer supported
-dnl See if we have the AppKit framework for building with Quartz graphics.
-
-if test "$_os" = "Darwin"; then
- if test "x$with_x" = "xyes"; then
- AC_MSG_ERROR([X11 build is no longer supported on MacOSX, please use the native aqua build])
- else
- AC_MSG_CHECKING([for /System/Library/Frameworks/AppKit.framework])
- if test -d "/System/Library/Frameworks/AppKit.framework/"; then
- AC_MSG_RESULT([yes])
- x_includes="no_x_includes"
- x_libraries="no_x_libraries"
- dnl disable some things used on other Unix versions but not on the aqua build
- enable_gtk=no
- else
- AC_MSG_ERROR([No AppKit.framewrok found])
- fi
- fi
-fi
-
-if test $_os = iOS -o $_os = Android; then
+if test $_os = Darwin -o $_os = iOS -o $_os = Android; then
enable_gtk=no
fi
@@ -7293,10 +7271,7 @@ AC_SUBST(ENABLE_NSPLUGIN)
dnl ***************************************
dnl testing for X libraries and includes...
dnl ***************************************
-if test "$_os" = "Darwin" -a "x$x_includes" = "xno_x_includes"; then
- dnl Mac OS X using Aqua graphics. Don't check for X11.
- :
-elif test "$_os" != "WINNT" -a "$_os" != "Android" -a "$_os" != "iOS"; then
+if test $_os != Darwin -a $_os != WINNT -a $_os != Android -a $_os != iOS; then
AC_PATH_X
AC_PATH_XTRA
CPPFLAGS="$CPPFLAGS $X_CFLAGS"