summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-01-20 18:59:24 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-02-05 19:34:05 -0600
commitee1cd2d9ff347acb50e3f29f817fa2a8fa076620 (patch)
treea31dfca438f050824bb54328b128a2cc17d6fe28 /configure.in
parent52a506fd30bd14dd6a74cf6c12e4e9180acc6839 (diff)
windows fix. some path need to be 'formatted' appropriately
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 18292dea0eae..55c062f8c8a1 100644
--- a/configure.in
+++ b/configure.in
@@ -7713,7 +7713,6 @@ the Windows SDK are installed.])
-o ! -x "$WINDOWS_SDK_HOME/bin/msitran.exe" ; then
AC_MSG_ERROR([Some (all) files of the Windows Installer SDK are missing, please install.])
fi
- SOLARINC="$SOLARINC -I$WINDOWS_SDK_HOME/include -I$COMPATH/include"
fi
if test -z "$WINDOWS_SDK_HOME"; then
@@ -7727,6 +7726,9 @@ the Windows SDK are installed.])
else
AC_MSG_ERROR([Found legacy Windows Platform SDK ($WINDOWS_SDK_HOME)])
fi
+ PathFormat "$WINDOWS_SDK_HOME"
+ WINDOWS_SDK_HOME="$formatted_path"
+ SOLARINC="$SOLARINC -I$WINDOWS_SDK_HOME/include -I$COMPATH/include"
fi
AC_SUBST(WINDOWS_SDK_HOME)
@@ -7752,7 +7754,6 @@ if test -n "$ENABLE_DIRECTX" -a "$_os" = "WINNT"; then
elif test -n "$with_directx_home"; then
DIRECTXSDK_HOME="$with_directx_home"
fi
- SOLARINC="$SOLARINC -I$DIRECTXSDK_HOME/include"
if test -f "$DIRECTXSDK_HOME/Include/ddraw.h" -o -f "$DIRECTXSDK_HOME/Include/d3d9.h" ; then
HAVE_DIRECTXSDK_H="yes"
@@ -7780,6 +7781,9 @@ if test -n "$ENABLE_DIRECTX" -a "$_os" = "WINNT"; then
else
AC_MSG_RESULT([no, hoping the necessary headers and libraries will be found anyway])
fi
+ PathFormat "$DIRECTXSDK_HOME"
+ DIRECTXSDK_HOME="$formatted_path"
+ SOLARINC="$SOLARINC -I$DIRECTXSDK_HOME/include"
fi
AC_SUBST(DIRECTXSDK_HOME)
AC_SUBST(DIRECTXSDK_LIB)