summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-08-22 03:51:09 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-08-22 03:51:43 -0500
commit9a20a1e1a96be6c5d79a9f19a536089a85960f3d (patch)
treeb81de9c1173993d899f352b1f03c41cdd2505fdc /configure.in
parentcf415295e71c5fa95d2ac3b2963ad20f96891acc (diff)
tolerate pkg-config on MacOSX when building mozilla, and allow to overide
Change-Id: Ia1c47ccda6c1fd94e8f4b1b6e6c1650abf791c74
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 62ec6a26509e..87ddf13c0ecd 100644
--- a/configure.in
+++ b/configure.in
@@ -1085,6 +1085,11 @@ AC_ARG_ENABLE(liblangtag,
implementation.]),
)
+AC_ARG_ENABLE(bogus-pkg-config,
+ AS_HELP_STRING([--enable-bogis-pkg-config],
+ [MACOSX only: on MacOSX pkg-config can cause trouble. by default if one is found in the PATH, an error is issued. This flag turn that error into a warning.]),
+)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -4413,7 +4418,16 @@ if test $_os = Darwin -a "$enable_mozilla" = no; then
if test "$PKG_CONFIG" = /usr/bin/pkg-config && ls -l /usr/bin/pkg-config | $GREP -q Mono.framework; then
AC_MSG_ERROR([yes, from Mono. This *will* break the build. Please remove or hide $PKG_CONFIG])
else
- AC_MSG_ERROR([yes, from unknown origin. This *will* break the build. Please remove or hide $PKG_CONFIG])
+ if test "$enable_mozilla" = "yes"; then
+ AC_MSG_RESULT([yes, from unkown origin])
+ add_warning "Having a $PKG_CONFIG might have unexpected consequences, please consider hiding it"
+ else
+ if test "$enable_bogus_pkg_config" = "yes"; then
+ AC_MSG_RESULT([yes, user-approved from unkown origin.])
+ else
+ AC_MSG_ERROR([yes, from unknown origin. This *will* break the build. Please remove or hide $PKG_CONFIG])
+ fi
+ fi
fi
else
AC_MSG_RESULT([no, good])