summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@novell.com>2010-12-09 15:57:22 +0000
committerMichael Meeks <michael.meeks@novell.com>2010-12-09 15:57:22 +0000
commit0820769fc1f577a118001cf8fd1cfd1aa45986e1 (patch)
tree659ac7d8af0d9e089250675fc5bf1d6fc7aa0db6 /configure.in
parent51f3f391a455180a50723e052c20304e535d2963 (diff)
rename to with_themes, and test scp2 a little
Conflicts: scp2/source/ooo/module_hidden_ooo.scp
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 24 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index b4461c04f3d8..601a9f230466 100644
--- a/configure.in
+++ b/configure.in
@@ -398,12 +398,6 @@ AC_ARG_ENABLE(extra-font,
[Add extra font content.]),
,)
-AC_ARG_ENABLE(theme,
- AS_HELP_STRING([--enable-theme="theme1 theme2..."],
- [Choose which themes to include. By default all available themes are included.
- Possible choices: crystal, hicontrast, oxygen, tango.]),
-,)
-
dnl ---------- Deprecated since 2010-11-05 ----------
AC_ARG_ENABLE(mysql-connector,
@@ -503,6 +497,12 @@ AC_ARG_WITH(vba-package-format,
--with-vba-package-format="extn"
],,)
+AC_ARG_WITH(theme,
+ AS_HELP_STRING([--with-theme="theme1 theme2..."],
+ [Choose which themes to include. By default those themes with an '*' are included.
+ Possible choices: *default, *crystal, *hicontrast, *oxygen, *tango, classic, industrial.]),
+,)
+
AC_ARG_WITH(extension-integration,
[
--with-extension-integration It will integrate the builded extensions
@@ -7078,6 +7078,24 @@ else
fi
dnl ===================================================================
+dnl Test which themes to include
+dnl ===================================================================
+AC_MSG_CHECKING([which themes to include])
+# if none given, use all available themes
+if test "z$enable_theme" = "z" -o "z$enable_theme" = "zyes"; then
+ enable_theme="default crystal hicontrast oxygen tango"
+fi
+
+ WITH_THEMES=""
+ for theme in $enable_theme
+ do
+ WITH_THEMES="$WITH_THEMES $theme"
+ SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[a-z]' '[A-Z]'`"
+ done
+ AC_MSG_RESULT([$WITH_THEMES])
+AC_SUBST(WITH_THEMES)
+
+dnl ===================================================================
dnl Test whether to integrate extensions into the product's installer
dnl ===================================================================
AC_MSG_CHECKING([for extensions integration])
@@ -7400,26 +7418,6 @@ fi
AC_SUBST(WITH_EXTRA_FONT)
dnl ===================================================================
-dnl Test which themes to include
-dnl ===================================================================
-AC_MSG_CHECKING([which themes to include])
-# if none given, use all available themes
-if test "z$enable_theme" = "z" -o "z$enable_theme" = "zyes"; then
- enable_theme="crystal hicontrast oxygen tango"
-fi
-
- ENABLE_THEMES=""
- for theme in $enable_theme
- do
- ENABLE_THEMES="$ENABLE_THEMES $theme"
- SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[a-z]' '[A-Z]'`"
- done
- AC_MSG_RESULT([$ENABLE_THEMES])
-
-AC_SUBST(ENABLE_THEMES)
-AC_SUBST(SCPDEFS)
-
-dnl ===================================================================
dnl Test whether to enable ActiveX embedding
dnl ===================================================================
if test "$_os" = "WINNT"; then