summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2010-12-09 13:17:41 +0100
committerMichael Meeks <michael.meeks@novell.com>2010-12-09 12:57:19 +0000
commit357d10916a37c5c2ede24a02c8e53066889e6782 (patch)
tree18ef01b302cd5f17b828129bc7488390a4e7a300 /configure.in
parenta516a964e1a19e92631c60ed207865e294e87bc8 (diff)
v3 of the configure.in/scp2 patch to allow selecting themes
DOH, here comes v3, I left a debug output in configure.in in v2, otherwise no change. Sorry Sebastian >From 6c379488250f5a3349dfc2d805f70a0f084fe07d Mon Sep 17 00:00:00 2001 From: Sebastian Spaeth <Sebastian@SSpaeth.de> Date: Thu, 9 Dec 2010 12:23:55 +0100 Subject: [PATCHv3] Introduce an --enable-theme="theme1 theme2..." option By default, we include all defaults as before, but if given, we can limit the number of included themes with e.g. --enable-theme="oxygen tango". This is passed through set_soenv and sets the environment variable ENABLE_THEMES="...." which can be used by the packimages makefile in the postprocess repository. It also adds defines in the form of THEME_OXYGEN that are being used in the scp2 module to decide if we should install the theme file or not. Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7fe1e954759b..7007d3f56b94 100755
--- a/configure.in
+++ b/configure.in
@@ -487,6 +487,12 @@ AC_ARG_ENABLE(extra-font,
[Add extra font content.]),
,)
+AC_ARG_ENABLE(theme,
+ AS_HELP_STRING([--enable-theme="theme1 theme2..."],
+ [Choose which themes to include. By default all available themes are included.
+ Possible choices: crystal, hicontrast, oxygen, tango.]),
+,)
+
dnl ---------- Deprecated since 2010-11-05 ----------
AC_ARG_ENABLE(mysql-connector,
@@ -7635,8 +7641,29 @@ else
fi
AC_SUBST(WITH_EXTRA_FONT)
+dnl ===================================================================
+dnl Test which themes to include
+dnl ===================================================================
+AC_MSG_CHECKING([which themes to include])
+# if none given, use all available themes
+if test "z$enable_theme" = "z" -o "z$enable_theme" = "zyes"; then
+ enable_theme="crystal hicontrast oxygen tango"
+fi
+
+ ENABLE_THEMES=""
+ for theme in $enable_theme
+ do
+ ENABLE_THEMES="$ENABLE_THEMES $theme"
+ SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[a-z]' '[A-Z]'`"
+ done
+ AC_MSG_RESULT([$ENABLE_THEMES])
+
+AC_SUBST(ENABLE_THEMES)
AC_SUBST(SCPDEFS)
+dnl ===================================================================
+dnl Test whether to enable ActiveX embedding
+dnl ===================================================================
if test "$_os" = "WINNT"; then
AC_MSG_CHECKING([whether to enable ActiveX embedding of LibO components])
if test "$enable_activex_component" = "yes" -o "$enable_activex_component" = "TRUE" -o "$enable_activex_component" = ""; then