summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-08-26 20:39:18 +0200
committerDavid Tardon <dtardon@redhat.com>2012-08-26 20:40:21 +0200
commit647080954f4985e3e16ad863efbe89e459b26f8e (patch)
tree248ed7a9ee3330cdd3596c270e6079943c208ae0 /configure.in
parent061652ff712da51b9f4c9efbc205869316149f70 (diff)
fix conditional inclusion of jdbc patch in hsqldb
Change-Id: I75e4566509d1851e7405d1738ffeaf58261233ea
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7d7ec8bc8533..1a23dff93565 100644
--- a/configure.in
+++ b/configure.in
@@ -7250,6 +7250,7 @@ dnl ===================================================================
dnl Check for system hsqldb
dnl ===================================================================
if test "$with_java" != "no"; then
+HSQLDB_USE_JDBC_4_1=
AC_MSG_CHECKING([which hsqldb to use])
if test "$with_system_hsqldb" = "yes"; then
AC_MSG_RESULT([external])
@@ -7290,9 +7291,18 @@ else
AC_MSG_RESULT([internal])
SYSTEM_HSQLDB=NO
BUILD_TYPE="$BUILD_TYPE HSQLDB"
+ AC_MSG_CHECKING([whether hsqldb should be built with JDBC 4.1])
+ javanumver=`$JAVAINTERPRETER -version 2>&1 | $AWK -v num=true -f $SRC_ROOT/solenv/bin/getcompver.awk`
+ if expr "$javanumver" '>=' 000100060000 > /dev/null; then
+ AC_MSG_RESULT([yes])
+ HSQLDB_USE_JDBC_4_1=YES
+ else
+ AC_MSG_RESULT([no])
+ fi
fi
AC_SUBST(SYSTEM_HSQLDB)
AC_SUBST(HSQLDB_JAR)
+AC_SUBST([HSQLDB_USE_JDBC_4_1])
fi
dnl ===================================================================