summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2010-12-17 12:14:27 +0100
committerFridrich Štrba <fridrich.strba@bluewin.ch>2010-12-17 12:14:27 +0100
commit6dd626c58f2ac752dd995d1b3da53e6bad75d2da (patch)
tree9f118437b3e7bbe943786199a24902f718e024a4 /configure.in
parent99ab4889f7995583160951e226844f66ca074239 (diff)
Add --with-helppack-integration configure option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3857afff93be..e431cbfd8ff6 100644
--- a/configure.in
+++ b/configure.in
@@ -510,6 +510,13 @@ AC_ARG_WITH(extension-integration,
Please use this switch to include any extension.],
,)
+AC_ARG_WITH(helppack-integration,
+[
+ --with-helppack-integration It will integrate the helppacks to the installer
+ of the product.
+ Please use this switch to include any helppack.],
+,)
+
AC_ARG_WITH(fonts,
[ --without-fonts OOo includes some third-party fonts to provide a reliable
basis for help content, templates, samples, etc.
@@ -7111,6 +7118,20 @@ fi
AC_SUBST(WITH_THEMES)
dnl ===================================================================
+dnl Test whether to integrate helppacks into the product's installer
+dnl ===================================================================
+AC_MSG_CHECKING([for helppack integration])
+if test "z$with_helppack_integration" = "z" -o "z$with_helppack_integration" = "zno" ; then
+ WITH_HELPPACK_INTEGRATION=NO
+ AC_MSG_RESULT([no integration])
+else
+ WITH_HELPPACK_INTEGRATION=YES
+ SCPDEFS="$SCPDEFS -DWITH_HELLPACK_INTEGRATION"
+ AC_MSG_RESULT([integration])
+fi
+AC_SUBST(WITH_HELPPACK_INTEGRATION)
+
+dnl ===================================================================
dnl Test whether to integrate extensions into the product's installer
dnl ===================================================================
AC_MSG_CHECKING([for extensions integration])