summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2011-01-29 12:51:38 +0000
committerCaolán McNamara <caolanm@redhat.com>2011-01-29 12:57:23 +0000
commit631eaf3312af57bc4b12f9769b436e936e174ac8 (patch)
treea3e8220e141825a4f38328e0e483367760e90648 /configure.in
parent5e4955a4f622d878c919ac7e6630001563790cf3 (diff)
Resolves: fdo#31271 wrong line break with (
(cherry picked from commit de475b03b02e4cac162b517f7d9f302b6134d546)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index db20f9d8171b..d9ae234b0a5f 100644
--- a/configure.in
+++ b/configure.in
@@ -5213,18 +5213,21 @@ if test -n "$with_system_icu" -o -n "$with_system_libs" && \
if test -z "$SYSTEM_GENCMN"; then
AC_MSG_ERROR([\"gencmn\" not found in \$PATH, install the icu development tool \"gencmn"\])
fi
+
+ AC_PATH_PROG( ICUCONFIG, icu-config)
AC_MSG_CHECKING([ICU version])
- AC_TRY_RUN([
-#include <unicode/uversion.h>
+ ICU_VERSION=`$ICUCONFIG --version`
+ ICU_MAJOR=`$ICUCONFIG --version | cut -d"." -f1`
+ ICU_MINOR=`$ICUCONFIG --version | cut -d"." -f2`
+ ICU_MICRO=`$ICUCONFIG --version | cut -d"." -f3`
-int main(int argc, char **argv) {
- if(U_ICU_VERSION_MAJOR_NUM < 4)
- return 1;
- else
- return 0;
-}
- ], [AC_MSG_RESULT(OK)], [AC_MSG_ERROR([not suitable, only >= 4.0 supported currently])])
- AC_LANG_POP([C++])
+ if test "$ICU_MAJOR" -ge "4"; then
+ AC_MSG_RESULT([OK])
+ else
+ AC_MSG_ERROR([not suitable, only >= 4.0 supported currently])
+ fi
+
+ AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])
SYSTEM_ICU=NO
@@ -5234,6 +5237,9 @@ AC_SUBST(SYSTEM_ICU)
AC_SUBST(SYSTEM_GENBRK)
AC_SUBST(SYSTEM_GENCCODE)
AC_SUBST(SYSTEM_GENCMN)
+AC_SUBST(ICU_MAJOR)
+AC_SUBST(ICU_MINOR)
+AC_SUBST(ICU_MICRO)
dnl ===================================================================
dnl Graphite